blob: c5b09a0c50a65d4cbe63f46750d324b47b03d413 [file] [log] [blame]
Patrick Williams93c203f2021-10-06 16:15:23 -05001DESCRIPTION = "the compiling PHP template engine"
2SECTION = "console/network"
3HOMEPAGE = "https://www.smarty.net/"
4
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=2c0f216b2120ffc367e20f2b56df51b3"
7
8DEPENDS = "php"
9
Andrew Geissler595f6302022-01-24 19:11:47 +000010SRC_URI = "git://github.com/smarty-php/smarty.git;protocol=https;tag=v${PV};branch=master"
Patrick Williams93c203f2021-10-06 16:15:23 -050011
12FILES:${PN} = "${datadir}/php/smarty3/"
13
14S = "${WORKDIR}/git"
15
16do_install() {
17 install -d ${D}${datadir}/php/smarty3/libs/
18 install -m 0644 ${S}/libs/*.php ${D}${datadir}/php/smarty3/libs/
19
20 install -d ${D}${datadir}/php/smarty3/libs/plugins
21 install -m 0644 ${S}/libs/plugins/*.php ${D}${datadir}/php/smarty3/libs/plugins/
22
23 install -d ${D}${datadir}/php/smarty3/libs/sysplugins
24 install -m 0644 ${S}/libs/sysplugins/*.php ${D}${datadir}/php/smarty3/libs/sysplugins/
25}