Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Wireless Central Regulatory Domain Database" |
| 2 | HOMEPAGE = "http://wireless.kernel.org/en/developers/Regulatory/CRDA" |
| 3 | SECTION = "net" |
| 4 | LICENSE = "ISC" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=07c4f6dea3845b02a18dc00c8c87699c" |
| 6 | |
| 7 | SRC_URI = "https://www.kernel.org/pub/software/network/${BPN}/${BP}.tar.xz" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 8 | SRC_URI[md5sum] = "4b5ba3f089db7fdb7b9daae6a7c1f2cb" |
| 9 | SRC_URI[sha256sum] = "cd917ed86b63ce8d93947979f1f18948f03a4ac0ad89ec25227b36ac00dc54bf" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 10 | |
| 11 | inherit bin_package allarch |
| 12 | |
| 13 | do_install() { |
| 14 | install -d -m0755 ${D}${nonarch_libdir}/crda |
| 15 | install -d -m0755 ${D}${sysconfdir}/wireless-regdb/pubkeys |
| 16 | install -m 0644 regulatory.bin ${D}${nonarch_libdir}/crda/regulatory.bin |
| 17 | install -m 0644 sforshee.key.pub.pem ${D}${sysconfdir}/wireless-regdb/pubkeys/sforshee.key.pub.pem |
| 18 | |
| 19 | install -m 0644 -D regulatory.db ${D}${nonarch_base_libdir}/firmware/regulatory.db |
| 20 | install -m 0644 regulatory.db.p7s ${D}${nonarch_base_libdir}/firmware/regulatory.db.p7s |
| 21 | } |
| 22 | |
| 23 | # Install static regulatory DB in /lib/firmware for kernel to load. |
| 24 | # This requires Linux kernel >= v4.15. |
| 25 | # For kernel <= v4.14, inherit the kernel_wireless_regdb.bbclass in kernel's recipe. |
| 26 | PACKAGES =+ "${PN}-static" |
| 27 | RCONFLICTS_${PN} = "${PN}-static" |
| 28 | |
| 29 | FILES_${PN}-static = " \ |
| 30 | ${nonarch_base_libdir}/firmware/regulatory.db \ |
| 31 | ${nonarch_base_libdir}/firmware/regulatory.db.p7s \ |
| 32 | " |
| 33 | |
| 34 | # Native users might want to use the source of regulatory DB. |
| 35 | # This is for example used by Linux kernel <= v4.14 and kernel_wireless_regdb.bbclass. |
| 36 | do_install_append_class-native() { |
| 37 | install -m 0644 -D db.txt ${D}${libdir}/crda/db.txt |
| 38 | } |
| 39 | |
| 40 | RSUGGESTS_${PN} = "crda" |
| 41 | |
| 42 | BBCLASSEXTEND = "native" |