Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | # SPDX-FileCopyrightText: Huawei Inc. |
| 2 | # |
| 3 | # SPDX-License-Identifier: MIT |
| 4 | |
| 5 | HOMEPAGE = "https://lvgl.io/" |
| 6 | DESCRIPTION = "LVGL is an OSS graphics library to create embedded GUI" |
| 7 | SUMMARY = "Light and Versatile Graphics Library" |
| 8 | LICENSE = "MIT" |
| 9 | LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=bf1198c89ae87f043108cea62460b03a" |
| 10 | |
| 11 | SRC_URI = "gitsm://github.com/lvgl/lvgl;destsuffix=${S};protocol=https;nobranch=1" |
| 12 | SRCREV = "d38eb1e689fa5a64c25e677275172d9c8a4ab2f0" |
| 13 | |
| 14 | REQUIRED_DISTRO_FEATURES = "wayland" |
| 15 | |
| 16 | inherit cmake |
| 17 | inherit features_check |
| 18 | |
| 19 | S = "${WORKDIR}/${PN}-${PV}" |
| 20 | |
| 21 | LVGL_CONFIG_LV_MEM_CUSTOM ?= "0" |
| 22 | |
| 23 | # Upstream does not support a default configuration |
| 24 | # but propose a default "disabled" template, which is used as reference |
| 25 | # More configuration can be done using external configuration variables |
| 26 | do_configure:prepend() { |
| 27 | [ -r "${S}/lv_conf.h" ] \ |
| 28 | || sed -e 's|#if 0 .*Set it to "1" to enable .*|#if 1 // Enabled|g' \ |
| 29 | -e "s|\(#define LV_MEM_CUSTOM .*\)0|\1${LVGL_CONFIG_LV_MEM_CUSTOM}|g" \ |
| 30 | < "${S}/lv_conf_template.h" > "${S}/lv_conf.h" |
| 31 | } |
| 32 | |
| 33 | FILES:${PN}-dev += "\ |
| 34 | ${includedir}/${PN}/ \ |
| 35 | ${includedir}/${PN}/lvgl/ \ |
| 36 | " |