Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SUMMARY = "library to read digital audio CDs with error correction" |
| 2 | HOMEPAGE = "http://www.gnu.org/software/libcdio/" |
| 3 | BUGTRUCKER = "https://github.com/rocky/libcdio-paranoia/issues/" |
| 4 | SECTION = "libs" |
| 5 | LICENSE = "GPLv3+" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 7 | DEPENDS = "libcdio" |
| 8 | |
| 9 | SRC_URI = "${GNU_MIRROR}/libcdio/${BP}.tar.bz2" |
| 10 | SRC_URI[sha256sum] = "33b1cf305ccfbfd03b43936975615000ce538b119989c4bec469577570b60e8a" |
| 11 | |
| 12 | inherit autotools pkgconfig |
| 13 | |
| 14 | PACKAGES += "${PN}-utils" |
| 15 | |
| 16 | FILES:${PN} = "${libdir}/${BPN}${SOLIB}" |
| 17 | FILES:${PN}-utils = "${bindir}/*" |
| 18 | |
| 19 | python libcdio_split_packages() { |
| 20 | libdir = d.expand('${libdir}') |
| 21 | do_split_packages(d, libdir, '^lib(.*)\.so\..*', 'lib%s', 'libcdio %s library', extra_depends='', allow_links=True) |
| 22 | } |
| 23 | |
| 24 | PACKAGESPLITFUNCS =+ "libcdio_split_packages" |