Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Framework for layout and rendering of internationalized text" |
| 2 | DESCRIPTION = "Pango is a library for laying out and rendering of text, \ |
| 3 | with an emphasis on internationalization. Pango can be used anywhere \ |
| 4 | that text layout is needed, though most of the work on Pango so far has \ |
| 5 | been done in the context of the GTK+ widget toolkit. Pango forms the \ |
| 6 | core of text and font handling for GTK+-2.x." |
| 7 | HOMEPAGE = "http://www.pango.org/" |
| 8 | BUGTRACKER = "http://bugzilla.gnome.org" |
| 9 | SECTION = "libs" |
| 10 | LICENSE = "LGPLv2.0+" |
| 11 | |
| 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7" |
| 13 | |
| 14 | GNOMEBASEBUILDCLASS = "meson" |
| 15 | |
| 16 | inherit gnomebase gtk-doc ptest-gnome upstream-version-is-even gobject-introspection |
| 17 | |
Andrew Geissler | 09209ee | 2020-12-13 08:44:15 -0600 | [diff] [blame] | 18 | GIR_MESON_ENABLE_FLAG = "enabled" |
| 19 | GIR_MESON_DISABLE_FLAG = "disabled" |
| 20 | |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 21 | SRC_URI[archive.sha256sum] = "d21f8b30dc8abdfc55de25656ecb88dc1105eeeb315e5e2a980dcef8010c2c80" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 22 | |
| 23 | DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi" |
| 24 | |
| 25 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \ |
| 26 | ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}" |
| 27 | |
| 28 | PACKAGECONFIG[x11] = ",,virtual/libx11 libxft" |
| 29 | PACKAGECONFIG[tests] = "-Dinstall-tests=true, -Dinstall-tests=false" |
| 30 | PACKAGECONFIG[thai] = ",,libthai" |
| 31 | |
| 32 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 33 | GIR_MESON_OPTION = 'introspection' |
| 34 | |
Andrew Geissler | 09209ee | 2020-12-13 08:44:15 -0600 | [diff] [blame] | 35 | do_configure_prepend() { |
| 36 | chmod +x ${S}/tests/*.py |
| 37 | } |
| 38 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 39 | do_configure_prepend_toolchain-clang() { |
| 40 | sed -i -e "/Werror=implicit-fallthrough/d" ${S}/meson.build |
| 41 | } |
| 42 | |
| 43 | LEAD_SONAME = "libpango-1.0*" |
| 44 | |
| 45 | FILES_${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}" |
| 46 | |
| 47 | RDEPENDS_${PN}-ptest += "cantarell-fonts" |
| 48 | RDEPENDS_${PN}-ptest_append_libc-glibc = " locale-base-en-us" |
| 49 | |
| 50 | RPROVIDES_${PN} += "pango-modules pango-module-indic-lang \ |
| 51 | pango-module-basic-fc pango-module-arabic-lang" |
| 52 | |
| 53 | BBCLASSEXTEND = "native nativesdk" |