Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "PT Sans Fonts" |
| 2 | DESCRIPTION = "The PT Sans TTF font set" |
| 3 | HOMEPAGE = "http://www.paratype.com/public/" |
| 4 | |
| 5 | SECTION = "x11/fonts" |
| 6 | |
| 7 | LICENSE = "ParaTypeFFL-1.3" |
| 8 | LIC_FILES_CHKSUM = "file://../PT%20Free%20Font%20License_eng.txt;md5=d720f3a281ed81c3f4cfc465e11b1d0d" |
| 9 | |
| 10 | inherit allarch fontcache |
| 11 | |
| 12 | # Downloading from fedora because upstream doesn't version its zip file |
| 13 | # and causes hash build failures |
| 14 | SRC_URI = "http://pkgs.fedoraproject.org/repo/pkgs/paratype-pt-sans-fonts/PTSans.zip/c3f5a0e20a75cf628387510a720924a7/PTSans.zip" |
| 15 | |
| 16 | SRC_URI[md5sum] = "c3f5a0e20a75cf628387510a720924a7" |
| 17 | SRC_URI[sha256sum] = "0164f824e03c32c99e8a225853ec168893a04a09ade132e93a674e85ae033b2e" |
| 18 | |
| 19 | do_install () { |
| 20 | install -d ${D}${datadir}/fonts/X11/TTF/ |
| 21 | cd .. |
| 22 | for i in *.ttf; do |
| 23 | install -m 0644 $i ${D}${prefix}/share/fonts/X11/TTF/${i} |
| 24 | done |
| 25 | } |
| 26 | |
| 27 | FILES_${PN} += "${datadir}" |
| 28 | |
| 29 | pkg_postinst_${PN} () { |
| 30 | set -x |
| 31 | for fontdir in `find $D/usr/lib/X11/fonts -type d`; do |
| 32 | mkfontdir $fontdir |
| 33 | mkfontscale $fontdir |
| 34 | done |
| 35 | for fontdir in `find $D/usr/share/fonts/X11 -type d`; do |
| 36 | mkfontdir $fontdir |
| 37 | mkfontscale $fontdir |
| 38 | done |
| 39 | } |