Patrick Williams | d849ec7 | 2016-08-17 14:59:38 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Utilities for manipulating POSIX capabilities in Go." |
| 2 | HOMEPAGE = "https://github.com/syndtr/gocapability" |
| 3 | SECTION = "devel/go" |
| 4 | LICENSE = "BSD-2-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a7304f5073e7be4ba7bffabbf9f2bbca" |
| 6 | |
| 7 | SRCNAME = "gocapability" |
| 8 | |
| 9 | PKG_NAME = "github.com/syndtr/${SRCNAME}" |
| 10 | SRC_URI = "git://${PKG_NAME}.git" |
| 11 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 12 | SRCREV = "2c00daeb6c3b45114c80ac44119e7b8801fdd852" |
| 13 | PV = "0.0+git${SRCPV}" |
Patrick Williams | d849ec7 | 2016-08-17 14:59:38 -0500 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | do_install() { |
| 18 | install -d ${D}${prefix}/local/go/src/${PKG_NAME} |
| 19 | cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ |
| 20 | } |
| 21 | |
| 22 | SYSROOT_PREPROCESS_FUNCS += "go_capability_sysroot_preprocess" |
| 23 | |
| 24 | go_capability_sysroot_preprocess () { |
| 25 | install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME} |
| 26 | cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME}) |
| 27 | } |
| 28 | |
| 29 | FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" |