Patrick Williams | d849ec7 | 2016-08-17 14:59:38 -0500 | [diff] [blame] | 1 | DESCRIPTION = "A golang registry for global request variables." |
| 2 | HOMEPAGE = "https://github.com/gorilla/context" |
| 3 | SECTION = "devel/go" |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c50f6bd9c1e15ed0bad3bea18e3c1b7f" |
| 6 | |
| 7 | SRCNAME = "context" |
| 8 | |
| 9 | PKG_NAME = "github.com/gorilla/${SRCNAME}" |
| 10 | SRC_URI = "git://${PKG_NAME}.git" |
| 11 | |
| 12 | SRCREV = "14f550f51af52180c2eefed15e5fd18d63c0a64a" |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | do_install() { |
| 17 | install -d ${D}${prefix}/local/go/src/${PKG_NAME} |
| 18 | cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ |
| 19 | } |
| 20 | |
| 21 | SYSROOT_PREPROCESS_FUNCS += "go_context_sysroot_preprocess" |
| 22 | |
| 23 | go_context_sysroot_preprocess () { |
| 24 | install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME} |
| 25 | cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME}) |
| 26 | } |
| 27 | |
| 28 | FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" |