Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Development package for building Applications that use numa" |
| 2 | HOMEPAGE = "http://oss.sgi.com/projects/libnuma/" |
| 3 | DESCRIPTION = "Simple NUMA policy support. It consists of a numactl program \ |
| 4 | to run other programs with a specific NUMA policy and a libnuma to do \ |
| 5 | allocations with NUMA policy in applications." |
| 6 | LICENSE = "GPL-2.0 & LGPL-2.1" |
| 7 | SECTION = "apps" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 8 | |
| 9 | inherit autotools-brokensep ptest |
| 10 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 11 | LIC_FILES_CHKSUM = "file://README.md;beginline=19;endline=32;md5=f8ff2391624f28e481299f3f677b21bb" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 12 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | SRCREV = "841253d1313b01a968c380cae4f498f20c46e5aa" |
| 14 | PV = "2.0.12+git${SRCPV}" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 15 | |
| 16 | SRC_URI = "git://github.com/numactl/numactl \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 17 | file://0001-fix-NULL-pointer-problem.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 18 | file://Fix-the-test-output-format.patch \ |
| 19 | file://Makefile \ |
| 20 | file://run-ptest \ |
| 21 | file://0001-define-run-test-target.patch \ |
| 22 | " |
| 23 | |
| 24 | S = "${WORKDIR}/git" |
| 25 | |
| 26 | # ARM does not currently support NUMA |
| 27 | COMPATIBLE_HOST = "^((?!arm).*)$" |
| 28 | |
| 29 | do_install() { |
| 30 | oe_runmake DESTDIR=${D} prefix=${D}/usr install |
| 31 | #remove the empty man2 directory |
| 32 | rm -r ${D}${mandir}/man2 |
| 33 | } |
| 34 | |
| 35 | do_compile_ptest() { |
| 36 | oe_runmake test |
| 37 | } |
| 38 | |
| 39 | do_install_ptest() { |
| 40 | #install tests binaries |
| 41 | local test_binaries="distance ftok mbind_mig_pages migrate_pages move_pages \ |
| 42 | mynode nodemap node-parse pagesize prefered randmap realloc_test \ |
| 43 | tbitmap tshared" |
| 44 | |
| 45 | [ ! -d ${D}/${PTEST_PATH}/test ] && mkdir -p ${D}/${PTEST_PATH}/test |
| 46 | for i in $test_binaries; do |
| 47 | install -m 0755 ${B}/test/.libs/$i ${D}${PTEST_PATH}/test |
| 48 | done |
| 49 | |
| 50 | local test_scripts="checktopology checkaffinity printcpu regress regress2 \ |
| 51 | shmtest runltp bind_range" |
| 52 | for i in $test_scripts; do |
| 53 | install -m 0755 ${B}/test/$i ${D}${PTEST_PATH}/test |
| 54 | done |
| 55 | |
| 56 | install -m 0755 ${WORKDIR}/Makefile ${D}${PTEST_PATH}/ |
| 57 | install -m 0755 ${B}/.libs/numactl ${D}${PTEST_PATH}/ |
| 58 | } |
| 59 | |
| 60 | RDEPENDS_${PN}-ptest = "bash" |