Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | DESCRIPTION = "Tooling for devicetree validation using YAML and jsonschema" |
| 2 | HOMEPAGE = "https://github.com/devicetree-org/dt-schema" |
| 3 | LICENSE = "BSD-2-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=457495c8fa03540db4a576bf7869e811" |
| 5 | |
| 6 | inherit pypi setuptools3 |
| 7 | |
| 8 | PYPI_PACKAGE = "dtschema" |
| 9 | |
| 10 | SRC_URI[sha256sum] = "f68af77fbce1ae00015c1fd2809fd20db8b72a27105c26a20e1ac0203aee1739" |
| 11 | |
| 12 | DEPENDS += "python3-setuptools-scm-native" |
| 13 | RDEPENDS:${PN} += "python3-ruamel-yaml python3-jsonschema python3-rfc3987" |
| 14 | |
| 15 | BBCLASSEXTEND = "native nativesdk" |