Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 1 | SUMMARY = "A library for bits of crypto UI and parsing etc" |
| 2 | DESCRIPTION = "GCR is a library for displaying certificates, and crypto UI, \ |
| 3 | accessing key stores. It also provides the viewer for crypto files on the \ |
| 4 | GNOME desktop." |
| 5 | HOMEPAGE = "https://gitlab.gnome.org/GNOME/gcr" |
| 6 | BUGTRACKER = "https://gitlab.gnome.org/GNOME/gcr/issues" |
| 7 | |
| 8 | LICENSE = "GPLv2" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605" |
| 10 | |
| 11 | DEPENDS = "gtk+3 p11-kit glib-2.0 libgcrypt \ |
| 12 | ${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'libxslt-native', '', d)}" |
| 13 | |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 14 | inherit gnomebase gtk-icon-cache gtk-doc features_check upstream-version-is-even vala gobject-introspection gettext |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 15 | # depends on gtk+3, but also x11 through gtk+-x11 |
| 16 | REQUIRED_DISTRO_FEATURES = "x11" |
| 17 | |
| 18 | SRC_URI[archive.md5sum] = "4af28919fb1dd36d93603e8230283b6f" |
| 19 | SRC_URI[archive.sha256sum] = "29df50974a90987af694c0fb8926a6b366e68cacd8abd813817cfe1eb5d54524" |
| 20 | |
| 21 | FILES_${PN} += " \ |
| 22 | ${datadir}/dbus-1 \ |
| 23 | ${datadir}/gcr-3 \ |
| 24 | " |
| 25 | |
| 26 | # http://errors.yoctoproject.org/Errors/Details/20229/ |
| 27 | ARM_INSTRUCTION_SET_armv4 = "arm" |
| 28 | ARM_INSTRUCTION_SET_armv5 = "arm" |
| 29 | ARM_INSTRUCTION_SET_armv6 = "arm" |
| 30 | |
| 31 | # These files may be out of date or missing our fixes |
| 32 | # libgcrypt.m4 in particular is calling into libgcrypt-config |
| 33 | do_configure_prepend() { |
| 34 | rm -f ${S}/build/m4/* |
| 35 | } |