blob: 8dc84e41257c3a6c3a02adb7de693d685f47d3ee [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "The glog library implements application-level logging. This \
2library provides logging APIs based on C++-style streams and various helper \
3macros."
4HOMEPAGE = "https://github.com/google/glog"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://COPYING;md5=dc9db360e0bbd4e46672f3fd91dd6c4b"
8
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009SRC_URI = " \
Brad Bishope42b3e32020-01-15 22:08:42 -050010 git://github.com/google/glog.git;nobranch=1 \
Andrew Geissler97771a32021-03-05 15:23:11 -060011 file://0001-Find-Libunwind-during-configure.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012"
13
Andrew Geissler97771a32021-03-05 15:23:11 -060014SRCREV = "96a2f23dca4cc7180821ca5f32e526314395d26a"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015
16S = "${WORKDIR}/git"
17
18inherit cmake
19
Andrew Geissler82c905d2020-04-13 13:39:40 -050020PACKAGECONFIG ?= "shared unwind"
21PACKAGECONFIG_remove_riscv64 = "unwind"
22PACKAGECONFIG_remove_riscv32 = "unwind"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023
Andrew Geissler82c905d2020-04-13 13:39:40 -050024PACKAGECONFIG[unwind] = "-DWITH_UNWIND=ON,-DWITH_UNWIND=OFF,libunwind,libunwind"
25PACKAGECONFIG[shared] = "-DBUILD_SHARED_LIBS=ON,-DBUILD_SHARED_LIBS=OFF,,"
Andrew Geisslera2681d92020-10-16 10:17:07 -050026
27do_configure_append() {
28 # remove WORKDIR info to improve reproducibility
29 if [ -f "${B}/config.h" ] ; then
30 sed -i 's/'$(echo ${WORKDIR} | sed 's_/_\\/_g')'/../g' ${B}/config.h
31 fi
32}