Brad Bishop | c1d3433 | 2019-09-09 14:56:00 -0400 | [diff] [blame] | 1 | DESCRIPTION = "A feature rich Remote Desktop Application written in GTK+" |
| 2 | HOMEPAGE = "https://remmina.org" |
| 3 | SECTION = "Support" |
| 4 | LICENSE = "GPLv2 & openssl" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=dab7215512044d49037272ce1ac4ea8f file://LICENSE.OpenSSL;md5=c1eb3cee0a4dea27503c531267a69769" |
Andrew Geissler | 7f40b71 | 2020-05-15 14:09:53 -0500 | [diff] [blame] | 6 | DEPENDS += "openssl freerdp gtk+3 gdk-pixbuf atk libgcrypt avahi libsodium libssh vte json-glib libsoup-2.4 libvncserver libsecret libxkbfile" |
Brad Bishop | c1d3433 | 2019-09-09 14:56:00 -0400 | [diff] [blame] | 7 | |
Brad Bishop | 5f78ea1 | 2019-09-10 07:20:03 -0400 | [diff] [blame] | 8 | |
| 9 | DEPENDS_append_libc-musl = " libexecinfo" |
Brad Bishop | c1d3433 | 2019-09-09 14:56:00 -0400 | [diff] [blame] | 10 | LDFLAGS_append_libc-musl = " -lexecinfo" |
| 11 | |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 12 | SRCREV = "6a8737111adebf571c46f35599cc62e7f7b0bd65" |
| 13 | SRC_URI = "git://gitlab.com/Remmina/Remmina;protocol=https;branch=rel/v1.4.11 \ |
Brad Bishop | c1d3433 | 2019-09-09 14:56:00 -0400 | [diff] [blame] | 14 | " |
Brad Bishop | c1d3433 | 2019-09-09 14:56:00 -0400 | [diff] [blame] | 15 | |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame] | 16 | PV .= "+git${SRCPV}" |
| 17 | |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 18 | S = "${WORKDIR}/git" |
Brad Bishop | c1d3433 | 2019-09-09 14:56:00 -0400 | [diff] [blame] | 19 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | inherit cmake features_check mime-xdg |
| 21 | REQUIRED_DISTRO_FEATURES = "x11" |
Brad Bishop | a891d15 | 2019-09-13 06:17:45 -0400 | [diff] [blame] | 22 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 23 | EXTRA_OECMAKE += "-DWITH_APPINDICATOR=OFF -DWITH_GETTEXT=OFF -DWITH_TRANSLATIONS=OFF" |
Brad Bishop | c1d3433 | 2019-09-09 14:56:00 -0400 | [diff] [blame] | 24 | |
| 25 | do_install_append(){ |
| 26 | # We dont need the extra stuff form other desktop environments |
| 27 | rm -rf ${D}/${datadir}/xsessions |
| 28 | rm -rf ${D}/${datadir}/metainfo |
| 29 | rm -rf ${D}/${datadir}/gnome-session |
| 30 | } |
| 31 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 32 | PACKAGECONFIG[spice] = "-DWITH_SPICE=ON, -DWITH_SPICE=OFF, spice spice-protocol" |
| 33 | |
Brad Bishop | c1d3433 | 2019-09-09 14:56:00 -0400 | [diff] [blame] | 34 | RDEPENDS_${PN} = "bash" |
| 35 | |
| 36 | FILES_${PN}_append = " ${datadir}/icons/hicolor/*" |