Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | SUMMARY = "Xilinx Runtime(XRT) driver module" |
| 2 | DESCRIPTION = "Xilinx Runtime driver module provides memory management and compute unit schedule" |
| 3 | |
Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 4 | LICENSE = "GPLv2 & Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=7d040f51aae6ac6208de74e88a3795f8" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 6 | |
Andrew Geissler | 7eb438a | 2020-11-30 19:53:16 -0600 | [diff] [blame] | 7 | BRANCH ?= "2020.2" |
Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 8 | REPO ?= "git://github.com/Xilinx/XRT.git;protocol=https" |
| 9 | BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}" |
| 10 | SRC_URI = "${REPO};${BRANCHARG}" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 11 | |
Andrew Geissler | 7eb438a | 2020-11-30 19:53:16 -0600 | [diff] [blame] | 12 | PV = "202020.2.8.0" |
| 13 | SRCREV ?= "f19a872233fbfe2eb933f25fa3d9a780ced774e5" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 14 | |
Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 15 | S = "${WORKDIR}/git/src/runtime_src/core/edge/drm/zocl" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 16 | |
| 17 | inherit module |
Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 18 | |
| 19 | pkg_postinst_ontarget_${PN}() { |
| 20 | #!/bin/sh |
| 21 | echo "Unloading old XRT Linux kernel modules" |
| 22 | ( rmmod zocl || true ) > /dev/null 2>&1 |
| 23 | echo "Loading new XRT Linux kernel modules" |
| 24 | modprobe zocl |
| 25 | } |