Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Perl module to manipulate and access URI strings" |
| 2 | DESCRIPTION = "This package contains the URI.pm module with friends. \ |
| 3 | The module implements the URI class. URI objects can be used to access \ |
| 4 | and manipulate the various components that make up these strings." |
| 5 | |
| 6 | SECTION = "libs" |
| 7 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 8 | |
| 9 | LIC_FILES_CHKSUM = "file://README;beginline=26;endline=30;md5=6c33ae5c87fd1c4897714e122dd9c23d" |
| 10 | |
| 11 | DEPENDS += "perl" |
| 12 | |
| 13 | SRC_URI = "http://www.cpan.org/authors/id/G/GA/GAAS/URI-${PV}.tar.gz" |
| 14 | |
| 15 | SRC_URI[md5sum] = "70f739be8ce28b8baba7c5920ffee4dc" |
| 16 | SRC_URI[sha256sum] = "1f92d3dc64acb8845e9917c945e22b9a5275aeb9ff924eb7873c3b7a5c0d2377" |
| 17 | |
| 18 | S = "${WORKDIR}/URI-${PV}" |
| 19 | |
| 20 | EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}" |
| 21 | |
| 22 | inherit cpan |
| 23 | |
| 24 | do_compile() { |
| 25 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" |
| 26 | cpan_do_compile |
| 27 | } |
| 28 | |
| 29 | BBCLASSEXTEND = "native" |