Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Postinstall scriptlets" |
| 2 | LICENSE = "MIT" |
| 3 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
| 4 | |
| 5 | FILES_${PN}_append = " ${datadir}/postinst-intercepts/*" |
| 6 | |
| 7 | do_configure[noexec] = "1" |
| 8 | do_compile[noexec] = "1" |
| 9 | |
| 10 | do_install() { |
| 11 | install -d ${D}${datadir}/postinst-intercepts |
| 12 | install -m 755 ${COREBASE}/scripts/postinst-intercepts/postinst_intercept ${D}${datadir}/postinst-intercepts/ |
| 13 | install -m 755 ${COREBASE}/scripts/postinst-intercepts/update_font_cache ${D}${datadir}/postinst-intercepts/ |
| 14 | install -m 755 ${COREBASE}/scripts/postinst-intercepts/update_icon_cache ${D}${datadir}/postinst-intercepts/ |
| 15 | install -m 755 ${COREBASE}/scripts/postinst-intercepts/update_pixbuf_cache ${D}${datadir}/postinst-intercepts/ |
| 16 | } |
| 17 | |
| 18 | inherit nativesdk |
| 19 | INHIBIT_DEFAULT_DEPS = "1" |