Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | SUMMARY = "Python library used to interact with Git repositories" |
| 2 | DESCRIPTION = "GitPython provides object model read and write access to \ |
| 3 | a git repository. Access repository information conveniently, alter the \ |
| 4 | index directly, handle remotes, or go down to low-level object database \ |
| 5 | access with big-files support." |
| 6 | HOMEPAGE = "http://github.com/gitpython-developers/GitPython" |
| 7 | SECTION = "devel/python" |
| 8 | LICENSE = "BSD-3-Clause" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8b8d26c37c1d5a04f9b0186edbebc183" |
| 10 | DEPENDS = "python-gitdb" |
| 11 | |
| 12 | SRC_URI = "http://pypi.python.org/packages/source/G/GitPython/GitPython-${PV}.tar.gz" |
| 13 | |
| 14 | SRC_URI[md5sum] = "d92d96a8da0fc77cf141d3e16084e094" |
| 15 | SRC_URI[sha256sum] = "85de72556781480a38897a77de5b458ae3838b0fd589593679a1b5f34d181d84" |
| 16 | |
| 17 | UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/GitPython/" |
| 18 | UPSTREAM_CHECK_REGEX = "/GitPython/(?P<pver>(\d+[\.\-_]*)+)" |
| 19 | |
| 20 | S = "${WORKDIR}/GitPython-${PV}" |
| 21 | |
| 22 | inherit setuptools |
| 23 | |
| 24 | RDEPENDS_${PN} += "python-gitdb python-lang python-io python-shell python-math python-re python-subprocess python-stringold python-unixadmin" |
| 25 | |
| 26 | BBCLASSEXTEND = "nativesdk" |