Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Python implementation of a sliding window memory map manager" |
| 2 | DESCRIPTION = "A pure Python implementation of a sliding memory map to \ |
| 3 | help unifying memory mapped access on 32 and 64 bit systems and to help \ |
| 4 | managing resources more efficiently." |
| 5 | HOMEPAGE = "http://github.com/gitpython-developers/GitPython" |
| 6 | SECTION = "devel/python" |
| 7 | LICENSE = "BSD" |
| 8 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e910b35b0ef4e1f665b9a75d6afb7709" |
| 9 | |
| 10 | SRC_URI = "http://pypi.python.org/packages/source/s/smmap/smmap-${PV}.tar.gz" |
| 11 | SRC_URI[md5sum] = "d7932d5ace206bf4ae15198cf36fb6ab" |
| 12 | SRC_URI[sha256sum] = "0e2b62b497bd5f0afebc002eda4d90df9d209c30ef257e8673c90a6b5c119d62" |
| 13 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 14 | UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/smmap/" |
| 15 | UPSTREAM_CHECK_REGEX = "/smmap/(?P<pver>(\d+[\.\-_]*)+)" |
| 16 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 17 | S = "${WORKDIR}/smmap-${PV}" |
| 18 | |
| 19 | inherit setuptools |
| 20 | |
| 21 | RDEPENDS_${PN} += "python-codecs python-mmap python-lang" |
| 22 | |
| 23 | BBCLASSEXTEND = "nativesdk" |