Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Interactive process viewer" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 2 | HOMEPAGE = "https://htop.dev" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 3 | SECTION = "console/utils" |
| 4 | LICENSE = "GPLv2" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=4099d367cd5e59b6d4fc1ee33accb891" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 6 | |
| 7 | DEPENDS = "ncurses" |
| 8 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 9 | SRC_URI = "git://github.com/htop-dev/htop.git \ |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 10 | file://0001-Use-pkg-config.patch \ |
Brad Bishop | 996bc45 | 2019-12-02 13:05:15 -0500 | [diff] [blame] | 11 | " |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 12 | SRCREV = "dace850fa6e27b5626115b366059258cfe4d60c9" |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 15 | |
| 16 | inherit autotools pkgconfig |
| 17 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 18 | PACKAGECONFIG ??= "cgroup \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 19 | taskstats \ |
| 20 | unicode \ |
| 21 | linux-affinity \ |
| 22 | delayacct" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 23 | PACKAGECONFIG[openvz] = "--enable-openvz,--disable-openvz" |
| 24 | PACKAGECONFIG[cgroup] = "--enable-cgroup,--disable-cgroup" |
| 25 | PACKAGECONFIG[vserver] = "--enable-vserver,--disable-vserver" |
| 26 | PACKAGECONFIG[taskstats] = "--enable-taskstats,--disable-taskstats" |
| 27 | PACKAGECONFIG[unicode] = "--enable-unicode,--disable-unicode" |
| 28 | PACKAGECONFIG[linux-affinity] = "--enable-linux-affinity,--disable-linux-affinity" |
| 29 | PACKAGECONFIG[hwloc] = "--enable-hwloc,--disable-hwloc,hwloc" |
| 30 | PACKAGECONFIG[setuid] = "--enable-setuid,--disable-setuid" |
| 31 | PACKAGECONFIG[delayacct] = "--enable-delayacct,--disable-delayacct,libnl" |