Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | SUMMARY = "Resource discovery and announcement over SSDP" |
| 2 | DESCRIPTION = "GSSDP implements resource discovery and announcement over SSDP (Simpe Service Discovery Protocol)." |
| 3 | LICENSE = "LGPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7" |
| 5 | DEPENDS = "glib-2.0 libsoup-2.4" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 6 | |
| 7 | SRC_URI = "${GNOME_MIRROR}/${BPN}/1.0/${BPN}-${PV}.tar.xz" |
| 8 | SRC_URI[md5sum] = "b30c9a406853c6a3a012d151d6e7ad2c" |
| 9 | SRC_URI[sha256sum] = "a1e17c09c7e1a185b0bd84fd6ff3794045a3cd729b707c23e422ff66471535dc" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 10 | |
| 11 | inherit autotools pkgconfig gobject-introspection vala gtk-doc |
| 12 | |
| 13 | # Copy vapigen.m4 so that it doesn't get removed by vala class |
| 14 | # (normally this would be the right thing to do, but in gssdp the vapigen.m4 has only a custom macro) |
| 15 | do_configure_prepend() { |
| 16 | cp -f ${S}/m4/vapigen.m4 ${S}/m4/vapigen-custom.m4 || true |
| 17 | } |
| 18 | |
| 19 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk', '', d)}" |
| 20 | PACKAGECONFIG[gtk] = "--with-gtk,--without-gtk,gtk+3" |
| 21 | |
| 22 | PACKAGES =+ "gssdp-tools" |
| 23 | |
| 24 | FILES_gssdp-tools = "${bindir}/gssdp* ${datadir}/gssdp/*.glade" |