Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "The tpm-tools package contains commands to allow the platform administrator the ability to manage and diagnose the platform's TPM." |
| 2 | DESCRIPTION = " \ |
| 3 | The tpm-tools package contains commands to allow the platform administrator \ |
| 4 | the ability to manage and diagnose the platform's TPM. Additionally, the \ |
| 5 | package contains commands to utilize some of the capabilities available \ |
| 6 | in the TPM PKCS#11 interface implemented in the openCryptoki project. \ |
| 7 | " |
| 8 | SECTION = "tpm" |
| 9 | LICENSE = "CPL-1.0" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=059e8cd6165cb4c31e351f2b69388fd9" |
| 11 | |
| 12 | DEPENDS = "libtspi openssl" |
| 13 | DEPENDS_class-native = "trousers-native" |
| 14 | |
| 15 | SRCREV = "bdf9f1bc8f63cd6fc370c2deb58d03ac55079e84" |
| 16 | SRC_URI = " \ |
| 17 | git://git.code.sf.net/p/trousers/tpm-tools \ |
| 18 | file://tpm-tools-extendpcr.patch \ |
| 19 | file://04-fix-FTBFS-clang.patch \ |
| 20 | file://05-openssl1.1_fix_data_mgmt.patch \ |
| 21 | file://openssl1.1_fix.patch \ |
| 22 | " |
| 23 | |
| 24 | inherit autotools-brokensep gettext |
| 25 | |
| 26 | S = "${WORKDIR}/git" |
| 27 | |
| 28 | do_configure_prepend () { |
| 29 | mkdir -p po |
| 30 | mkdir -p m4 |
| 31 | cp -R po_/* po/ |
| 32 | touch po/Makefile.in.in |
| 33 | touch m4/Makefile.am |
| 34 | } |
| 35 | |
| 36 | BBCLASSEXTEND = "native" |