Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "VMcore extraction tool" |
| 2 | DESCRIPTION = "\ |
| 3 | This program is used to extract a subset of the memory available either \ |
| 4 | via /dev/mem or /proc/vmcore (for crashdumps). It is used to get memory \ |
| 5 | images without extra uneeded information (zero pages, userspace programs, \ |
| 6 | etc). \ |
| 7 | " |
| 8 | HOMEPAGE = "http://makedumpfile.sourceforge.net" |
| 9 | |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 11 | LICENSE = "GPLv2.0" |
| 12 | |
| 13 | DEPENDS = "bzip2 zlib elfutils" |
| 14 | RDEPENDS_${PN}-tools = "perl ${PN}" |
| 15 | |
Andrew Geissler | 1548c07 | 2019-02-22 16:03:50 -0600 | [diff] [blame^] | 16 | # arm and aarch64 would compile but has never been tested upstream. mips would not compile. |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 17 | # |
Andrew Geissler | 1548c07 | 2019-02-22 16:03:50 -0600 | [diff] [blame^] | 18 | COMPATIBLE_HOST = "(x86_64|i.86|powerpc|arm|aarch64).*-linux" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 19 | |
| 20 | PACKAGES =+ "${PN}-tools" |
| 21 | FILES_${PN}-tools = "${bindir}/*.pl" |
| 22 | |
| 23 | SRC_URI = "\ |
| 24 | ${SOURCEFORGE_MIRROR}/makedumpfile/${BPN}-${PV}.tar.gz \ |
| 25 | file://0001-makedumpfile-replace-hardcode-CFLAGS.patch \ |
| 26 | file://0002-mem_section-Support-only-46-bit-for-MAX_PHYSMEM_BITS.patch \ |
| 27 | " |
| 28 | SRC_URI[md5sum] = "7dfbca19f487604c271e2892ba07f4bd" |
| 29 | SRC_URI[sha256sum] = "7e06f72d5f291fcab9e92975f405a76e37d4f7fc8fa4172f199636398ae812b1" |
| 30 | |
| 31 | UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/makedumpfile/files/makedumpfile/" |
| 32 | UPSTREAM_CHECK_REGEX = "makedumpfile/(?P<pver>\d+(\.\d+)+)/" |
| 33 | |
| 34 | SECTION = "base" |
| 35 | |
| 36 | # If we do not specify TARGET, makedumpfile will build for the host but use the |
| 37 | # target gcc. |
| 38 | # |
| 39 | EXTRA_OEMAKE = "\ |
| 40 | LINKTYPE=static \ |
| 41 | TARGET=${TARGET_ARCH} \ |
| 42 | " |
| 43 | |
| 44 | do_install () { |
| 45 | mkdir -p ${D}/usr/bin |
| 46 | install -m 755 ${S}/makedumpfile ${D}/usr/bin |
| 47 | install -m 755 ${S}/makedumpfile-R.pl ${D}/usr/bin |
| 48 | |
| 49 | mkdir -p ${D}/usr/share/man/man8 |
| 50 | install -m 644 ${S}/makedumpfile.8.gz ${D}/usr/share/man/man8 |
| 51 | |
| 52 | mkdir -p ${D}/usr/share/man/man5 |
| 53 | install -m 644 ${S}/makedumpfile.conf.5.gz ${D}/usr/share/man/man5 |
| 54 | |
| 55 | mkdir -p ${D}/etc/ |
| 56 | install -m 644 ${S}/makedumpfile.conf ${D}/etc/makedumpfile.conf.sample |
| 57 | } |