Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Library containing NEON-optimized implementations for a common set of functions" |
| 2 | HOMEPAGE = "http://projectne10.github.io/Ne10/" |
| 3 | LICENSE = "BSD-3-Clause" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e7fe20c9be97be5579e3ab5d92d3a218" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 5 | SECTION = "libs" |
| 6 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 7 | SRC_URI = "git://github.com/projectNe10/Ne10.git \ |
| 8 | file://0001-CMakeLists.txt-Remove-mthumb-interwork.patch \ |
| 9 | file://0001-Dont-specify-march-explicitly.patch \ |
| 10 | " |
| 11 | SRCREV = "18c4c982a595dad069cd8df4932aefb1d257591f" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 12 | |
| 13 | S = "${WORKDIR}/git" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 14 | PV .= "gitr+${SRCPV}" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 15 | |
| 16 | inherit cmake |
| 17 | |
| 18 | NE10_TARGET_ARCH = "" |
| 19 | EXTRA_OECMAKE = '-DGNULINUX_PLATFORM=ON -DNE10_BUILD_SHARED=ON -DNE10_LINUX_TARGET_ARCH="${NE10_TARGET_ARCH}"' |
| 20 | |
| 21 | COMPATIBLE_MACHINE_aarch64 = "(.*)" |
| 22 | COMPATIBLE_MACHINE_armv7a = "(.*)" |
| 23 | |
| 24 | python () { |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 25 | if any(t.startswith('armv7') for t in d.getVar('TUNE_FEATURES').split()): |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 26 | d.setVar('NE10_TARGET_ARCH', 'armv7') |
| 27 | bb.debug(2, 'Building Ne10 for armv7') |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 28 | elif any(t.startswith('aarch64') for t in d.getVar('TUNE_FEATURES').split()): |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 29 | d.setVar('NE10_TARGET_ARCH', 'aarch64') |
| 30 | bb.debug(2, 'Building Ne10 for aarch64') |
| 31 | else: |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 32 | raise bb.parse.SkipRecipe("Incompatible with archs other than armv7 and aarch64") |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 33 | } |
| 34 | |
| 35 | do_install() { |
| 36 | install -d ${D}${libdir} |
| 37 | install -d ${D}${includedir} |
| 38 | install -m 0644 ${S}/inc/NE10*.h ${D}${includedir}/ |
| 39 | install -m 0644 ${B}/modules/libNE10.a ${D}${libdir}/ |
| 40 | install -m 0755 ${B}/modules/libNE10.so.* ${D}${libdir}/ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 41 | cp -d ${B}/modules/libNE10.so ${D}${libdir}/ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 42 | } |
| 43 | |
| 44 | # ERROR: QA Issue: ELF binary 'ne10/1.2.1-r0/packages-split/ne10/usr/lib/libNE10.so.10' has relocations in .text [textrel] |
| 45 | # ERROR: QA Issue: ELF binary 'ne10/1.2.1-r0/packages-split/ne10/usr/lib/libNE10.so.10' has relocations in .text [textrel] |
| 46 | INSANE_SKIP_${PN} += "textrel" |