Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Smart card library and applications" |
| 2 | DESCRIPTION = "OpenSC is a tool for accessing smart card devices. Basic\ |
| 3 | functionality (e.g. SELECT FILE, READ BINARY) should work on any ISO\ |
| 4 | 7816-4 compatible smart card. Encryption and decryption using private\ |
| 5 | keys on the smart card is possible with PKCS\ |
| 6 | such as the FINEID (Finnish Electronic IDentity) card. Swedish Posten\ |
| 7 | eID cards have also been confirmed to work." |
| 8 | |
| 9 | HOMEPAGE = "http://www.opensc-project.org/opensc/" |
| 10 | SECTION = "System Environment/Libraries" |
| 11 | |
| 12 | SRC_URI = "https://snapshot.debian.org/archive/debian/20180521T101428Z/pool/main/o/opensc/opensc_0.18.0.orig.tar.gz \ |
| 13 | file://0001-Fixed-gcc-8-compilation-errors-1353.patch \ |
| 14 | " |
| 15 | |
| 16 | SRC_URI[md5sum] = "bce516f752e0db5327aa06cc0136fe27" |
| 17 | SRC_URI[sha256sum] = "6ef62b00e8fdbe3e386c3ee25c2cadb56c1931ea42f1a11dce8c947f51b45033" |
| 18 | |
| 19 | DEPENDS = "openct pcsc-lite virtual/libiconv openssl" |
| 20 | |
| 21 | LICENSE = "LGPLv2+" |
| 22 | LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34" |
| 23 | |
| 24 | inherit autotools pkgconfig |
| 25 | |
| 26 | S = "${WORKDIR}/OpenSC-${PV}" |
| 27 | EXTRA_OECONF = " \ |
| 28 | --disable-static \ |
| 29 | --enable-openct \ |
| 30 | --disable-pcsc \ |
| 31 | --disable-ctapi \ |
| 32 | --disable-doc \ |
| 33 | " |
| 34 | EXTRA_OEMAKE = "DESTDIR=${D}" |
| 35 | |
| 36 | RDEPENDS_${PN} = "readline" |
| 37 | |
| 38 | FILES_${PN} += "\ |
| 39 | ${libdir}/opensc-pkcs11.so \ |
| 40 | ${libdir}/onepin-opensc-pkcs11.so \ |
| 41 | ${libdir}/pkcs11-spy.so \ |
| 42 | " |
| 43 | FILES_${PN}-dev += "\ |
| 44 | ${libdir}/pkcs11/opensc-pkcs11.so \ |
| 45 | ${libdir}/pkcs11/onepin-opensc-pkcs11.so \ |
| 46 | ${libdir}/pkcs11/pkcs11-spy.so \ |
| 47 | " |