blob: a4d631f8ea7eb55972cd9eb1ba6f59218038ba36 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Dependency management tool for Golang"
2HOMEPAGE = "https://github.com/golang/dep"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=1bad315647751fab0007812f70d42c0d"
5
6GO_IMPORT = "github.com/golang/dep"
7SRC_URI = "git://${GO_IMPORT} \
8 file://0001-Add-support-for-mips-mips64.patch;patchdir=src/github.com/golang/dep \
9 "
10
11# Points to 0.5.0 tag
12SRCREV = "224a564abe296670b692fe08bb63a3e4c4ad7978"
13
14inherit go
15
16GO_INSTALL = "${GO_IMPORT}/cmd/dep"
17
18RDEPENDS_${PN}-dev += "bash"
19
20BBCLASSEXTEND = "native nativesdk"
21
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080022# For compiling ptest on mips and mips64, the current go-dep version fails with the go 1.11 toolchain.
23# error message: vet config not found
24PTEST_ENABLED_mips = "0"
25PTEST_ENABLED_mips64 = "0"