Andrew Geissler | 7f40b71 | 2020-05-15 14:09:53 -0500 | [diff] [blame] | 1 | SUMMARY = "Full-featured IRC plugin: multi-servers, proxy support, IPv6, SASL authentication, nicklist, DCC, and many other features" |
| 2 | HOMEPAE = "https://weechat.org/" |
| 3 | SECTION = "net" |
| 4 | LICENSE = "GPLv3" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=c678957b0c8e964aa6c70fd77641a71e" |
| 6 | |
| 7 | DEPENDS = "openssl zlib icu libgcrypt gnutls curl aspell" |
| 8 | |
| 9 | SRC_URI = "https://weechat.org/files/src/weechat-${PV}.tar.xz \ |
| 10 | file://0001-use-pkg-config-for-gcrypt-instead.patch \ |
| 11 | " |
| 12 | SRC_URI[sha256sum] = "553ea295edad3b03cf88e6029c21e7bde32ff1cc026d35386ba9da3e56a6018c" |
| 13 | |
| 14 | inherit cmake pkgconfig |
| 15 | |
| 16 | PACKAGECONFIG ??= " ncurses python" |
| 17 | PACKAGECONFIG[ncurses] = "-DENABLE_NCURSES=ON,-DENABLE_NCURSES=OFF,ncurses" |
| 18 | PACKAGECONFIG[python] = "-DENABLE_PYTHON=ON,-DENABLE_PYTHON=OFF,python3" |
| 19 | |
| 20 | EXTRA_OECMAKE_append = " -DENABLE_PHP=OFF -DENABLE_TCL=OFF -DENABLE_LUA=OFF -DENABLE_JAVASCRIPT=OFF -DENABLE_RUBY=OFF -DENABLE_GUILE=OFF -DENABLE_PERL=OFF -DENABLE_ASPELL=ON" |
| 21 | |
| 22 | do_configure_prepend(){ |
| 23 | # Make sure we get dependencies from recipe-sysroot |
| 24 | sed -i -e 's# /usr/bin# ${RECIPE_SYSROOT}/${bindir}/#g' ${S}/cmake/FindPerl.cmake |
| 25 | sed -i -e 's# /usr/local/bin##g' ${S}/cmake/FindPerl.cmake |
| 26 | sed -i -e 's# /usr/pkg/bin##g' ${S}/cmake/FindPerl.cmake |
| 27 | } |
| 28 | |
| 29 | do_install_append(){ |
| 30 | rm -rf ${D}/${datadir} |
| 31 | } |
| 32 | |