Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Security-focused ELF files checking tool" |
| 2 | DESCRIPTION = "This is a small set of various PaX aware and related \ |
| 3 | utilities for ELF binaries. It can check ELF binary files and running \ |
| 4 | processes for issues that might be relevant when using ELF binaries \ |
| 5 | along with PaX, such as non-PIC code or executable stack and heap." |
| 6 | HOMEPAGE = "http://www.gentoo.org/proj/en/hardened/pax-utils.xml" |
| 7 | LICENSE = "GPLv2+" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a" |
| 9 | |
| 10 | SRC_URI = "http://gentoo.osuosl.org/distfiles/pax-utils-${PV}.tar.xz" |
| 11 | |
| 12 | SRC_URI[md5sum] = "d731f5385682a7a62ee2e7b7dacc13a7" |
| 13 | SRC_URI[sha256sum] = "f69a9938e4af7912d26d585094bc0203e43571a990fdd048319088a8b8ad906f" |
| 14 | |
| 15 | RDEPENDS_${PN} += "bash python" |
| 16 | |
| 17 | do_install() { |
| 18 | oe_runmake PREFIX=${D}${prefix} DESTDIR=${D} install |
| 19 | } |
| 20 | |
| 21 | BBCLASSEXTEND = "native" |