Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Python bindings for the Cairo canvas library" |
| 2 | HOMEPAGE = "http://cairographics.org/pycairo" |
| 3 | BUGTRACKER = "http://bugs.freedesktop.org" |
| 4 | SECTION = "python-devel" |
| 5 | LICENSE = "LGPLv2.1 & MPL-1.1" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=f2e071ab72978431b294a0d696327421 \ |
| 7 | file://COPYING-LGPL-2.1;md5=fad9b3332be894bab9bc501572864b29 \ |
| 8 | file://COPYING-MPL-1.1;md5=bfe1f75d606912a4111c90743d6c7325" |
| 9 | |
| 10 | # cairo >= 1.8.8 |
| 11 | DEPENDS = "cairo" |
| 12 | PR = "r2" |
| 13 | |
| 14 | SRC_URI = "http://cairographics.org/releases/py2cairo-${PV}.tar.bz2" |
| 15 | |
| 16 | SRC_URI[md5sum] = "20337132c4ab06c1146ad384d55372c5" |
| 17 | SRC_URI[sha256sum] = "d30439f06c2ec1a39e27464c6c828b6eface3b22ee17b2de05dc409e429a7431" |
| 18 | |
| 19 | S = "${WORKDIR}/py2cairo-${PV}" |
| 20 | |
| 21 | inherit distutils pkgconfig |
| 22 | |
| 23 | BBCLASSEXTEND = "native" |
| 24 | |
| 25 | do_configure() { |
| 26 | BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} ./waf configure --prefix=${D}${prefix} --libdir=${D}${libdir} |
| 27 | } |
| 28 | |
| 29 | do_compile() { |
| 30 | ./waf build ${PARALLEL_MAKE} |
| 31 | } |
| 32 | |
| 33 | do_install() { |
| 34 | ./waf install |
| 35 | sed \ |
| 36 | -e 's:@prefix@:${prefix}:' \ |
| 37 | -e 's:@VERSION@:${PV}:' \ |
| 38 | -e 's:@includedir@:${includedir}:' \ |
| 39 | pycairo.pc.in > pycairo.pc |
| 40 | install -m 0644 pycairo.pc ${D}${libdir}/pkgconfig/ |
| 41 | } |