Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | require recipes-devtools/python/python.inc |
| 2 | |
| 3 | PR = "${INC_PR}.0" |
| 4 | PYTHON_MAJMIN = "3.4" |
| 5 | DISTRO_SRC_URI ?= "file://sitecustomize.py" |
| 6 | DISTRO_SRC_URI_linuxstdbase = "" |
| 7 | SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \ |
| 8 | file://12-distutils-prefix-is-inside-staging-area.patch \ |
| 9 | file://python-config.patch \ |
| 10 | file://000-cross-compile.patch \ |
| 11 | file://020-dont-compile-python-files.patch \ |
| 12 | file://030-fixup-include-dirs.patch \ |
| 13 | file://070-dont-clean-ipkg-install.patch \ |
| 14 | file://080-distutils-dont_adjust_files.patch \ |
| 15 | file://110-enable-zlib.patch \ |
| 16 | file://130-readline-setup.patch \ |
| 17 | file://150-fix-setupterm.patch \ |
| 18 | file://python-3.3-multilib.patch \ |
| 19 | file://03-fix-tkinter-detection.patch \ |
| 20 | file://avoid_warning_about_tkinter.patch \ |
| 21 | file://shutil-follow-symlink-fix.patch \ |
| 22 | file://0001-h2py-Fix-issue-13032-where-it-fails-with-UnicodeDeco.patch \ |
| 23 | file://sysroot-include-headers.patch \ |
| 24 | file://unixccompiler.patch \ |
| 25 | file://makerace.patch \ |
| 26 | ${DISTRO_SRC_URI} \ |
| 27 | file://sysconfig.py-add-_PYTHON_PROJECT_SRC.patch \ |
| 28 | file://setup.py-check-cross_compiling-when-get-FLAGS.patch \ |
| 29 | " |
| 30 | SRC_URI[md5sum] = "7d092d1bba6e17f0d9bd21b49e441dd5" |
| 31 | SRC_URI[sha256sum] = "b5b3963533768d5fc325a4d7a6bd6f666726002d696f1d399ec06b043ea996b8" |
| 32 | |
| 33 | LIC_FILES_CHKSUM = "file://LICENSE;md5=dd98d01d471fac8d8dbdd975229dba03" |
| 34 | |
| 35 | S = "${WORKDIR}/Python-${PV}" |
| 36 | |
| 37 | EXTRANATIVEPATH += "bzip2-native" |
| 38 | DEPENDS = "openssl-native bzip2-replacement-native zlib-native readline-native sqlite3-native" |
| 39 | |
| 40 | inherit native |
| 41 | |
| 42 | RPROVIDES += "python3-distutils-native python3-compression-native python3-textutils-native python3-core-native" |
| 43 | |
| 44 | EXTRA_OECONF_append = " --bindir=${bindir}/${PN} --without-ensurepip" |
| 45 | |
| 46 | EXTRA_OEMAKE = '\ |
| 47 | BUILD_SYS="" \ |
| 48 | HOST_SYS="" \ |
| 49 | LIBC="" \ |
| 50 | STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \ |
| 51 | STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \ |
| 52 | LIB=${baselib} \ |
| 53 | ARCH=${TARGET_ARCH} \ |
| 54 | ' |
| 55 | |
| 56 | # No ctypes option for python 3 |
| 57 | PYTHONLSBOPTS = "" |
| 58 | |
| 59 | do_configure_append() { |
| 60 | autoreconf --verbose --install --force --exclude=autopoint ../Python-${PV}/Modules/_ctypes/libffi |
| 61 | } |
| 62 | |
| 63 | do_install() { |
| 64 | install -d ${D}${libdir}/pkgconfig |
| 65 | oe_runmake 'DESTDIR=${D}' install |
| 66 | if [ -e ${WORKDIR}/sitecustomize.py ]; then |
| 67 | install -m 0644 ${WORKDIR}/sitecustomize.py ${D}/${libdir}/python${PYTHON_MAJMIN} |
| 68 | fi |
| 69 | install -d ${D}${bindir}/${PN} |
| 70 | install -m 0755 Parser/pgen ${D}${bindir}/${PN} |
| 71 | |
| 72 | # Make sure we use /usr/bin/env python |
| 73 | for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do |
| 74 | sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT |
| 75 | done |
| 76 | } |