Patrick Williams | d849ec7 | 2016-08-17 14:59:38 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Open source network boot firmware" |
| 2 | HOMEPAGE = "http://ipxe.org" |
| 3 | LICENSE = "GPLv2" |
| 4 | DEPENDS = "binutils-native perl-native syslinux mtools-native cdrtools-native" |
| 5 | LIC_FILES_CHKSUM = "file://../COPYING;md5=8ca43cbc842c2336e835926c2166c28b" |
| 6 | |
| 7 | SRCREV = "8c43891db4eb131d019360ccfb619f235b17eb58" |
| 8 | PV = "gitr${SRCPV}" |
| 9 | PR = "r0" |
| 10 | |
| 11 | SRC_URI = "git://git.ipxe.org/ipxe.git;protocol=git" |
| 12 | |
| 13 | FILES_${PN} = "/usr/share/firmware/*.rom" |
| 14 | |
| 15 | EXTRA_OEMAKE = "NO_WERROR=1" |
| 16 | #PARALLEL_MAKE="" |
| 17 | |
| 18 | S = "${WORKDIR}/git/src" |
| 19 | |
| 20 | do_configure() { |
| 21 | sed -i s#^ISOLINUX_BIN[\ \\t]*=.*#ISOLINUX_BIN\ =\ ${STAGING_DIR_TARGET}/usr/lib/syslinux/isolinux.bin# arch/i386/Makefile |
| 22 | } |
| 23 | |
| 24 | do_compile() { |
| 25 | oe_runmake |
| 26 | } |
| 27 | |
| 28 | do_install() { |
| 29 | install -d ${D}/usr/share/firmware |
| 30 | install ${S}/bin/*.rom ${D}/usr/share/firmware/ |
| 31 | } |