Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "ModemManager is a daemon controlling broadband devices/connections" |
| 2 | DESCRIPTION = "ModemManager is a DBus-activated daemon which controls mobile broadband (2G/3G/4G) devices and connections" |
| 3 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/ModemManager/" |
| 4 | LICENSE = "GPL-2.0 & LGPL-2.1" |
| 5 | LIC_FILES_CHKSUM = " \ |
| 6 | file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 7 | file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \ |
| 8 | " |
| 9 | |
| 10 | inherit gnomebase gettext systemd vala gobject-introspection bash-completion |
| 11 | |
| 12 | DEPENDS = "glib-2.0 libgudev dbus-glib intltool-native" |
| 13 | |
| 14 | SRC_URI = "http://www.freedesktop.org/software/ModemManager/ModemManager-${PV}.tar.xz \ |
Andrew Geissler | 1548c07 | 2019-02-22 16:03:50 -0600 | [diff] [blame] | 15 | file://0001-Do-not-set-Wno-unused-but-set-variable.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 16 | " |
| 17 | |
| 18 | SRC_URI[md5sum] = "a49c9f73e46c7b89e5efedda250d22c0" |
| 19 | SRC_URI[sha256sum] = "96f2a5f0ed15532b4c4c185b756fdc0326e7c2027cea26a1264f91e098260f80" |
| 20 | |
| 21 | S = "${WORKDIR}/ModemManager-${PV}" |
| 22 | |
| 23 | PACKAGECONFIG ??= "mbim qmi polkit \ |
| 24 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ |
| 25 | " |
| 26 | |
| 27 | PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,," |
| 28 | PACKAGECONFIG[polkit] = "--with-polkit=yes,--with-polkit=no,polkit" |
| 29 | # Support WWAN modems and devices which speak the Mobile Interface Broadband Model (MBIM) protocol. |
| 30 | PACKAGECONFIG[mbim] = "--with-mbim,--with-mbim=no,libmbim" |
| 31 | # Support WWAN modems and devices which speak the Qualcomm MSM Interface (QMI) protocol. |
| 32 | PACKAGECONFIG[qmi] = "--with-qmi,--without-qmi,libqmi" |
| 33 | |
| 34 | EXTRA_OECONF = " \ |
| 35 | --with-udev-base-dir=${nonarch_base_libdir}/udev \ |
| 36 | " |
Andrew Geissler | 1548c07 | 2019-02-22 16:03:50 -0600 | [diff] [blame] | 37 | CFLAGS_append_toolchain-gcc = " -Wno-unused-but-set-variable" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 38 | |
| 39 | FILES_${PN} += " \ |
| 40 | ${datadir}/icons \ |
| 41 | ${datadir}/polkit-1 \ |
| 42 | ${datadir}/dbus-1 \ |
| 43 | ${libdir}/ModemManager \ |
| 44 | ${systemd_unitdir}/system \ |
| 45 | " |
| 46 | |
| 47 | FILES_${PN}-dev += " \ |
| 48 | ${libdir}/ModemManager/*.la \ |
| 49 | " |
| 50 | |
| 51 | FILES_${PN}-staticdev += " \ |
| 52 | ${libdir}/ModemManager/*.a \ |
| 53 | " |
| 54 | |
| 55 | FILES_${PN}-dbg += "${libdir}/ModemManager/.debug" |
| 56 | |
| 57 | SYSTEMD_SERVICE_${PN} = "ModemManager.service" |