Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 1 | SUMMARY = "ModemManager is a daemon controlling broadband devices/connections" |
| 2 | DESCRIPTION = "ModemManager is a DBus-activated daemon which controls mobile broadband (2G/3G/4G) devices and connections" |
| 3 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/ModemManager/" |
| 4 | LICENSE = "GPL-2.0 & LGPL-2.1" |
| 5 | LIC_FILES_CHKSUM = " \ |
| 6 | file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 7 | file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \ |
| 8 | " |
| 9 | |
| 10 | inherit gnomebase gettext systemd vala gobject-introspection bash-completion |
| 11 | |
| 12 | DEPENDS = "glib-2.0 libgudev dbus-glib intltool-native" |
| 13 | |
| 14 | SRC_URI = "http://www.freedesktop.org/software/ModemManager/ModemManager-${PV}.tar.xz \ |
| 15 | " |
| 16 | |
| 17 | SRC_URI[md5sum] = "a49c9f73e46c7b89e5efedda250d22c0" |
| 18 | SRC_URI[sha256sum] = "96f2a5f0ed15532b4c4c185b756fdc0326e7c2027cea26a1264f91e098260f80" |
| 19 | |
| 20 | S = "${WORKDIR}/ModemManager-${PV}" |
| 21 | |
| 22 | PACKAGECONFIG ??= "mbim qmi polkit \ |
| 23 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ |
| 24 | " |
| 25 | |
| 26 | PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,," |
| 27 | PACKAGECONFIG[polkit] = "--with-polkit=yes,--with-polkit=no,polkit" |
| 28 | # Support WWAN modems and devices which speak the Mobile Interface Broadband Model (MBIM) protocol. |
| 29 | PACKAGECONFIG[mbim] = "--with-mbim,--with-mbim=no,libmbim" |
| 30 | # Support WWAN modems and devices which speak the Qualcomm MSM Interface (QMI) protocol. |
| 31 | PACKAGECONFIG[qmi] = "--with-qmi,--without-qmi,libqmi" |
| 32 | |
| 33 | EXTRA_OECONF = " \ |
| 34 | --with-udev-base-dir=${nonarch_base_libdir}/udev \ |
| 35 | " |
| 36 | |
| 37 | FILES_${PN} += " \ |
| 38 | ${datadir}/icons \ |
| 39 | ${datadir}/polkit-1 \ |
| 40 | ${datadir}/dbus-1 \ |
| 41 | ${libdir}/ModemManager \ |
| 42 | ${systemd_unitdir}/system \ |
| 43 | " |
| 44 | |
| 45 | FILES_${PN}-dev += " \ |
| 46 | ${libdir}/ModemManager/*.la \ |
| 47 | " |
| 48 | |
| 49 | FILES_${PN}-staticdev += " \ |
| 50 | ${libdir}/ModemManager/*.a \ |
| 51 | " |
| 52 | |
| 53 | FILES_${PN}-dbg += "${libdir}/ModemManager/.debug" |
| 54 | |
| 55 | SYSTEMD_SERVICE_${PN} = "ModemManager.service" |