Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "User space daemon for extended IEEE 802.11 management" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 2 | HOMEPAGE = "http://w1.fi/hostapd/" |
| 3 | SECTION = "kernel/userland" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://hostapd/README;md5=8aa4e8c78b59b12016c4cb2d0a8db350" |
| 6 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 7 | DEPENDS = "libnl openssl" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 8 | |
| 9 | SRC_URI = " \ |
| 10 | http://w1.fi/releases/hostapd-${PV}.tar.gz \ |
| 11 | file://defconfig \ |
| 12 | file://init \ |
| 13 | file://hostapd.service \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 14 | file://0001-hostapd-Avoid-key-reinstallation-in-FT-handshake.patch \ |
| 15 | file://0002-Prevent-reinstallation-of-an-already-in-use-group-ke.patch \ |
| 16 | file://0003-Extend-protection-of-GTK-IGTK-reinstallation-of-WNM-.patch \ |
| 17 | file://0004-Prevent-installation-of-an-all-zero-TK.patch \ |
| 18 | file://0005-Fix-PTK-rekeying-to-generate-a-new-ANonce.patch \ |
| 19 | file://0006-TDLS-Reject-TPK-TK-reconfiguration.patch \ |
| 20 | file://0007-FT-Do-not-allow-multiple-Reassociation-Response-fram.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 21 | file://hostapd-CVE-2018-14526.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 22 | " |
| 23 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 24 | SRC_URI[md5sum] = "eaa56dce9bd8f1d195eb62596eab34c7" |
| 25 | SRC_URI[sha256sum] = "01526b90c1d23bec4b0f052039cc4456c2fd19347b4d830d1d58a0a6aea7117d" |
| 26 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 27 | S = "${WORKDIR}/hostapd-${PV}" |
| 28 | B = "${WORKDIR}/hostapd-${PV}/hostapd" |
| 29 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 30 | inherit update-rc.d systemd pkgconfig distro_features_check |
| 31 | |
| 32 | CONFLICT_DISTRO_FEATURES = "openssl-no-weak-ciphers" |
| 33 | |
| 34 | INITSCRIPT_NAME = "hostapd" |
| 35 | |
| 36 | SYSTEMD_SERVICE_${PN} = "hostapd.service" |
| 37 | SYSTEMD_AUTO_ENABLE_${PN} = "disable" |
| 38 | |
| 39 | do_configure_append() { |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 40 | install -m 0644 ${WORKDIR}/defconfig ${B}/.config |
| 41 | } |
| 42 | |
| 43 | do_compile() { |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 44 | export CFLAGS="-MMD -O2 -Wall -g" |
| 45 | export EXTRA_CFLAGS="${CFLAGS}" |
| 46 | make V=1 |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 47 | } |
| 48 | |
| 49 | do_install() { |
| 50 | install -d ${D}${sbindir} ${D}${sysconfdir}/init.d ${D}${systemd_unitdir}/system/ |
| 51 | install -m 0644 ${B}/hostapd.conf ${D}${sysconfdir} |
| 52 | install -m 0755 ${B}/hostapd ${D}${sbindir} |
| 53 | install -m 0755 ${B}/hostapd_cli ${D}${sbindir} |
| 54 | install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd |
| 55 | install -m 0644 ${WORKDIR}/hostapd.service ${D}${systemd_unitdir}/system/ |
| 56 | sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/hostapd.service |
| 57 | } |
| 58 | |
| 59 | CONFFILES_${PN} += "${sysconfdir}/hostapd.conf" |