Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame^] | 1 | SUMMARY = "haveged - A simple entropy daemon" |
| 2 | DESCRIPTION = "The haveged project is an attempt to provide an easy-to-use, unpredictable random number generator based upon an adaptation of the HAVEGE algorithm. Haveged was created to remedy low-entropy conditions in the Linux random device that can occur under some workloads, especially on headless servers." |
| 3 | AUTHOR = "Gary Wuertz" |
| 4 | HOMEPAGE = "http://www.issihosts.com/haveged/index.html" |
| 5 | LICENSE = "GPLv3" |
| 6 | LIC_FILES_CHKSUM="file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 7 | |
| 8 | # v1.9.4 |
| 9 | SRCREV = "faa40ff345af194d3253f5fb030403e3c9831c36" |
| 10 | SRC_URI = "git://github.com/jirka-h/haveged.git \ |
| 11 | file://haveged-init.d-Makefile.am-add-missing-dependency.patch \ |
| 12 | " |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | UPSTREAM_CHECK_URI = "https://github.com/jirka-h/haveged/releases" |
| 16 | |
| 17 | inherit autotools update-rc.d systemd |
| 18 | |
| 19 | EXTRA_OECONF = "\ |
| 20 | --enable-nistest=yes \ |
| 21 | --enable-olt=yes \ |
| 22 | --enable-threads=no \ |
| 23 | " |
| 24 | |
| 25 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| 26 | PACKAGECONFIG[systemd] = "--enable-init=service.redhat --enable-initdir=${systemd_system_unitdir}, --enable-init=sysv.redhat, systemd" |
| 27 | |
| 28 | INITSCRIPT_PACKAGES = "${PN}" |
| 29 | INITSCRIPT_NAME = "haveged" |
| 30 | INITSCRIPT_PARAMS_${PN} = "defaults 9" |
| 31 | |
| 32 | SYSTEMD_PACKAGES = "${PN}" |
| 33 | SYSTEMD_SERVICE_${PN} = "haveged.service" |
| 34 | |
| 35 | do_install_append() { |
| 36 | # The exit status is 143 when the service is stopped |
| 37 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
| 38 | sed -i '/ExecStart/a SuccessExitStatus=143' ${D}${systemd_system_unitdir}/haveged.service |
| 39 | fi |
| 40 | } |
| 41 | |
| 42 | MIPS_INSTRUCTION_SET = "mips" |