Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame^] | 1 | DESCRIPTION = "libblockdev is a C library supporting GObject introspection for manipulation of \ |
| 2 | block devices. It has a plugin-based architecture where each technology (like \ |
| 3 | LVM, Btrfs, MD RAID, Swap,...) is implemented in a separate plugin, possibly \ |
| 4 | with multiple implementations (e.g. using LVM CLI or the new LVM DBus API)." |
| 5 | HOMEPAGE = "http://rhinstaller.github.io/libblockdev/" |
| 6 | LICENSE = "LGPLv2+" |
| 7 | SECTION = "devel/lib" |
| 8 | |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c" |
| 10 | |
| 11 | inherit autotools python3native gobject-introspection |
| 12 | |
| 13 | SRCREV = "cb308566c3c5222b8422f78997a1742713b265a9" |
| 14 | SRC_URI = " \ |
| 15 | git://github.com/rhinstaller/libblockdev;branch=master \ |
| 16 | " |
| 17 | |
| 18 | S = "${WORKDIR}/git" |
| 19 | |
| 20 | FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}" |
| 21 | |
| 22 | PACKAGECONFIG ??= "python3 lvm dm kmod parted fs escrow btrfs crypto mdraid kbd mpath nvdimm" |
| 23 | PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3" |
| 24 | PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python2" |
| 25 | PACKAGECONFIG[lvm] = "--with-lvm, --without-lvm, multipath-tools, lvm2" |
| 26 | PACKAGECONFIG[lvm-dbus] = "--with-lvm_dbus, --without-lvm_dbus, multipath-tools, lvm2" |
| 27 | PACKAGECONFIG[dm] = "--with-dm, --without-dm, multipath-tools, lvm2" |
| 28 | PACKAGECONFIG[dmraid] = "--with-dmraid, --without-dmraid" |
| 29 | PACKAGECONFIG[kmod] = "--with-kbd, --without-kbd, kmod" |
| 30 | PACKAGECONFIG[parted] = "--with-part, --without-part, parted" |
| 31 | PACKAGECONFIG[fs] = "--with-fs, --without-fs, util-linux" |
| 32 | PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native" |
| 33 | PACKAGECONFIG[nvdimm] = "--with-nvdimm, --without-nvdimm, ndctl util-linux" |
| 34 | PACKAGECONFIG[vdo] = "--with-vdo, --without-vdo" |
| 35 | PACKAGECONFIG[escrow] = "--with-escrow, --without-escrow, nss volume-key" |
| 36 | PACKAGECONFIG[btrfs] = "--with-btrfs,--without-btrfs,libbytesize btrfs-tools" |
| 37 | PACKAGECONFIG[crypto] = "--with-crypto,--without-crypto,cryptsetup nss volume-key" |
| 38 | PACKAGECONFIG[mdraid] = "--with-mdraid,--without-mdraid,libbytesize" |
| 39 | PACKAGECONFIG[kbd] = "--with-kbd,--without-kbd,libbytesize" |
| 40 | PACKAGECONFIG[mpath] = "--with-mpath,--without-mpath, multipath-tools, lvm2" |
| 41 | |
| 42 | export GIR_EXTRA_LIBS_PATH="${B}/src/utils/.libs" |
| 43 | |