Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "A New System Troubleshooting Tool Built for the Way You Work" |
| 2 | DESCRIPTION = "Sysdig is open source, system-level exploration: capture \ |
| 3 | system state and activity from a running Linux instance, then save, \ |
| 4 | filter and analyze." |
| 5 | HOMEPAGE = "http://www.sysdig.org/" |
| 6 | LICENSE = "GPLv2" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 8 | |
| 9 | inherit cmake pkgconfig |
| 10 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 11 | OECMAKE_GENERATOR = "Unix Makefiles" |
| 12 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 13 | DEPENDS = "luajit zlib ncurses" |
| 14 | RDEPENDS_${PN} = "bash" |
| 15 | |
| 16 | SRC_URI = "git://github.com/draios/sysdig.git;branch=master \ |
| 17 | file://0001-libsinsp-Port-to-build-with-lua-5.2.patch \ |
| 18 | file://0001-Fix-build-with-musl-backtrace-APIs-are-glibc-specifi.patch \ |
| 19 | " |
| 20 | SRCREV = "85d16f33a82a17f87ccdbc088749271c71d87013" |
| 21 | PV = "0.1.102+git${SRCPV}" |
| 22 | |
| 23 | S = "${WORKDIR}/git" |
| 24 | |
| 25 | DIR_ETC="/etc" |
| 26 | EXTRA_OECMAKE = ' -DUSE_BUNDLED_LUAJIT="OFF" \ |
| 27 | -DUSE_BUNDLED_ZLIB="OFF" \ |
| 28 | -DBUILD_DRIVER="OFF" \ |
| 29 | -DUSE_BUNDLED_NCURSES="OFF" \ |
| 30 | -DDIR_ETC="${DIR_ETC}" \ |
| 31 | ' |
| 32 | |
| 33 | FILES_${PN} += " \ |
| 34 | ${DIR_ETC}/* \ |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 35 | ${datadir}/zsh/* \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 36 | ${prefix}/src/* \ |
| 37 | " |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 38 | |
| 39 | # luajit not supported on Aarch64 |
| 40 | COMPATIBLE_HOST = "^(?!aarch64).*" |
| 41 | |