Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 1 | DESCRIPTION = "jackdmp is a C++ version of the JACK low-latency audio \ |
| 2 | server for multi-processor machines. It is a new implementation of the \ |
| 3 | JACK server core features that aims in removing some limitations of \ |
| 4 | the JACK1 design. The activation system has been changed for a data \ |
| 5 | flow model and lock-free programming techniques for graph access have \ |
| 6 | been used to have a more dynamic and robust system." |
| 7 | SECTION = "libs/multimedia" |
| 8 | |
| 9 | LICENSE = "GPLv2 & LGPLv2.1" |
| 10 | LIC_FILES_CHKSUM = " \ |
| 11 | file://common/jack/control.h;beginline=2;endline=21;md5=e6df0bf30cde8b3b825451459488195d \ |
| 12 | file://common/jack/jack.h;beginline=1;endline=19;md5=6b736ed6b810592b135480a5e853392e \ |
| 13 | " |
| 14 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 15 | DEPENDS = "libsamplerate0 libsndfile1 readline" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 16 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 17 | SRC_URI = "git://github.com/jackaudio/jack2.git \ |
| 18 | file://0001-Python-3.7-fixes-2126.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame^] | 19 | file://0001-Fix-OSX-build.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 20 | " |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 21 | SRCREV = "c1647819eed6d11f94b21981d9c869629299f357" |
| 22 | PV = "1.9.12" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 23 | S = "${WORKDIR}/git" |
| 24 | |
| 25 | inherit waf pkgconfig |
| 26 | |
| 27 | PACKAGECONFIG ??= "alsa" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 28 | PACKAGECONFIG[alsa] = "--alsa=yes,--alsa=no,alsa-lib" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame^] | 29 | # --dbus only stops building jackd -> add --classic |
| 30 | PACKAGECONFIG[dbus] = "--dbus --classic,,dbus" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 31 | PACKAGECONFIG[opus] = "--opus=yes,--opus=no,libopus" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 32 | |
| 33 | # portaudio is for windows builds only |
| 34 | EXTRA_OECONF = "--portaudio=no" |
| 35 | |
| 36 | PACKAGES =+ "libjack jack-server jack-utils" |
| 37 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 38 | RDEPENDS_jack-dev_remove = "${PN} (= ${EXTENDPKGV})" |
| 39 | |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 40 | FILES_libjack = "${libdir}/*.so.* ${libdir}/jack/*.so" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame^] | 41 | FILES_jack-server = " \ |
| 42 | ${datadir}/dbus-1/services \ |
| 43 | ${bindir}/jackdbus \ |
| 44 | ${bindir}/jackd \ |
| 45 | " |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 46 | FILES_jack-utils = "${bindir}/*" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame^] | 47 | |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 48 | FILES_${PN}-doc += " ${datadir}/jack-audio-connection-kit/reference/html/* " |