Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Interactive Connectivity Establishment library" |
| 2 | DESCRIPTION = "Libnice is an implementation of the IETF's draft Interactive Connectivity Establishment standard (ICE)." |
| 3 | HOMEPAGE = "http://nice.freedesktop.org/wiki/" |
| 4 | SRC_URI = "http://nice.freedesktop.org/releases/libnice-${PV}.tar.gz" |
| 5 | SRC_URI[md5sum] = "c9b9b74b8ae1b3890e4bd93f1b70e8ff" |
| 6 | SRC_URI[sha256sum] = "be120ba95d4490436f0da077ffa8f767bf727b82decf2bf499e39becc027809c" |
| 7 | |
| 8 | LICENSE = "LGPLv2.1 & MPLv1.1" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=9c42325015702feda4f4d2f19a55b767 \ |
| 10 | file://COPYING.LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \ |
| 11 | file://COPYING.MPL;md5=3c617710e51cdbe0fc00716f056dfb1a \ |
| 12 | " |
| 13 | |
| 14 | DEPENDS = "glib-2.0 gnutls" |
| 15 | |
| 16 | PACKAGECONFIG ??= "gstreamer1.0" |
| 17 | PACKAGECONFIG[gupnp] = "--enable-gupnp,--disable-gupnp,gupnp-igd" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 18 | PACKAGECONFIG[gstreamer1.0] = "--with-gstreamer,--without-gstreamer,gstreamer1.0 gstreamer1.0-plugins-base" |
| 19 | |
| 20 | inherit autotools pkgconfig gtk-doc gobject-introspection |
| 21 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame^] | 22 | EXTRA_OECONF += "--without-gstreamer-0.10" |
| 23 | |
| 24 | FILES_${PN} += "${libdir}/gstreamer-1.0/*.so" |
| 25 | FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.la" |
| 26 | FILES_${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a" |
| 27 | FILES_${PN}-dbg += "${libdir}/gstreamer-1.0/.debug" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 28 | |
| 29 | do_configure_prepend() { |
| 30 | mkdir ${S}/m4 || true |
| 31 | } |
| 32 | |
| 33 | do_compile_append() { |
| 34 | for i in $(find ${B} -name "*.pc") ; do |
| 35 | sed -i -e s:${STAGING_DIR_TARGET}::g \ |
| 36 | -e s:/${TARGET_SYS}::g \ |
| 37 | $i |
| 38 | done |
| 39 | } |