Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame^] | 1 | SUMMARY = "Library for controlling team network device" |
| 2 | HOMEPAGE = "http://www.libteam.org/" |
| 3 | SECTION = "libs/network" |
| 4 | |
| 5 | LICENSE = "LGPLv2.1" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" |
| 7 | |
| 8 | DEPENDS = "libnl libdaemon jansson" |
| 9 | |
| 10 | SRC_URI = "git://github.com/jpirko/libteam \ |
| 11 | file://0001-include-sys-select.h-for-fd_set-definition.patch \ |
| 12 | file://0002-teamd-Re-adjust-include-header-order.patch \ |
| 13 | file://0001-team_basic_test.py-disable-RedHat-specific-test.patch \ |
| 14 | file://run-ptest \ |
| 15 | " |
| 16 | SRCREV = "903950c7fcf28c32f4b62d9d1c07c0234e8378a2" |
| 17 | |
| 18 | S = "${WORKDIR}/git" |
| 19 | |
| 20 | inherit autotools pkgconfig ptest |
| 21 | |
| 22 | FILES_${PN} = "${libdir}/libteam${SOLIBS} \ |
| 23 | " |
| 24 | |
| 25 | PACKAGES += "${PN}-dctl ${PN}-utils" |
| 26 | FILES_${PN}-dctl = "${libdir}/libteamdctl${SOLIBS} \ |
| 27 | " |
| 28 | FILES_${PN}-utils = "${bindir}/bond2team \ |
| 29 | ${bindir}/teamd \ |
| 30 | ${bindir}/teamdctl \ |
| 31 | ${bindir}/teamnl \ |
| 32 | " |
| 33 | |
| 34 | RDEPENDS_${PN}-utils = "bash" |
| 35 | RDEPENDS_${PN}-ptest = "python" |
| 36 | |
| 37 | do_install_ptest() { |
| 38 | install ${S}/scripts/team_basic_test.py ${D}${PTEST_PATH}/ |
| 39 | } |