Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame^] | 1 | SUMMARY = "A PKCS#11 interface for TPM2 hardware" |
| 2 | DESCRIPTION = "PKCS #11 is a Public-Key Cryptography Standard that defines a standard method to access cryptographic services from tokens/ devices such as hardware security modules (HSM), smart cards, etc. In this project we intend to use a TPM2 device as the cryptographic token." |
| 3 | SECTION = "security/tpm" |
| 4 | LICENSE = "BSD-2-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b748af41ef1300c98e105b3b7ec4ecc1" |
| 6 | |
| 7 | DEPENDS = "autoconf-archive pkgconfig dstat sqlite3 openssl libtss2-dev tpm2-tools" |
| 8 | |
| 9 | SRC_URI = "git://github.com/tpm2-software/tpm2-pkcs11.git \ |
| 10 | file://bootstrap_fixup.patch \ |
| 11 | " |
| 12 | |
| 13 | SRCREV = "3107d89b406ecd9c007884613733c9a344ef6d39" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | inherit autotools-brokensep pkgconfig |
| 18 | |
| 19 | do_configure_prepend () { |
| 20 | ${S}/bootstrap |
| 21 | } |