Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame^] | 1 | SUMMARY = "Utilities to access MS-DOS disks without mounting them" |
| 2 | DESCRIPTION = "Mtools is a collection of utilities to access MS-DOS disks from GNU and Unix without mounting them." |
| 3 | HOMEPAGE = "http://www.gnu.org/software/mtools/" |
| 4 | SECTION = "optional" |
| 5 | LICENSE = "GPLv3" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 7 | |
| 8 | DEPENDS += "virtual/libiconv" |
| 9 | |
| 10 | RDEPENDS_${PN}_libc-glibc = "glibc-gconv-ibm850" |
| 11 | RRECOMMENDS_${PN}_libc-glibc = "\ |
| 12 | glibc-gconv-ibm437 \ |
| 13 | glibc-gconv-ibm737 \ |
| 14 | glibc-gconv-ibm775 \ |
| 15 | glibc-gconv-ibm851 \ |
| 16 | glibc-gconv-ibm852 \ |
| 17 | glibc-gconv-ibm855 \ |
| 18 | glibc-gconv-ibm857 \ |
| 19 | glibc-gconv-ibm860 \ |
| 20 | glibc-gconv-ibm861 \ |
| 21 | glibc-gconv-ibm862 \ |
| 22 | glibc-gconv-ibm863 \ |
| 23 | glibc-gconv-ibm865 \ |
| 24 | glibc-gconv-ibm866 \ |
| 25 | glibc-gconv-ibm869 \ |
| 26 | " |
| 27 | SRC_URI[md5sum] = "f750246a65ee6f9d2e82d10b03a0aaaf" |
| 28 | SRC_URI[sha256sum] = "1bc197199ea1c2c317f597879486eeb817f3199b526d94cc6841624768d910df" |
| 29 | |
| 30 | SRC_URI = "${GNU_MIRROR}/mtools/mtools-${PV}.tar.bz2 \ |
| 31 | file://mtools-makeinfo.patch \ |
| 32 | file://no-x11.gplv3.patch \ |
| 33 | file://0001-Continue-even-if-fs-size-is-not-divisible-by-sectors.patch \ |
| 34 | file://0001-remove-LOCK_NB-to-use-blocking-request.patch \ |
| 35 | file://clang_UNUSED.patch \ |
| 36 | " |
| 37 | |
| 38 | SRC_URI_append_class-native = " file://disable-hardcoded-configs.patch" |
| 39 | |
| 40 | inherit autotools texinfo distro_features_check |
| 41 | |
| 42 | EXTRA_OECONF = "--without-x" |
| 43 | |
| 44 | BBCLASSEXTEND = "native nativesdk" |
| 45 | |
| 46 | PACKAGECONFIG ??= "" |
| 47 | PACKAGECONFIG[libbsd] = "ac_cv_lib_bsd_main=yes,ac_cv_lib_bsd_main=no,libbsd" |
| 48 | |
| 49 | do_install_prepend () { |
| 50 | # Create bindir to fix parallel installation issues |
| 51 | mkdir -p ${D}/${bindir} |
| 52 | mkdir -p ${D}/${datadir} |
| 53 | } |