Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame^] | 1 | SUMMARY = "Additional utilities for the opkg package manager" |
| 2 | SUMMARY_update-alternatives-opkg = "Utility for managing the alternatives system" |
| 3 | SECTION = "base" |
| 4 | HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils" |
| 5 | LICENSE = "GPLv2+" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 7 | file://opkg.py;beginline=2;endline=18;md5=63ce9e6bcc445181cd9e4baf4b4ccc35" |
| 8 | PROVIDES += "${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'virtual/update-alternatives', '', d)}" |
| 9 | |
| 10 | SRC_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/${BPN}/snapshot/${BPN}-${PV}.tar.gz \ |
| 11 | file://0001-Switch-all-scripts-to-use-Python-3.x.patch \ |
| 12 | file://0001-opkg-build-do-not-set-mtime-on-data.tar.X.patch \ |
| 13 | " |
| 14 | UPSTREAM_CHECK_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils/refs/" |
| 15 | |
| 16 | |
| 17 | SRC_URI[md5sum] = "6e1c2eae96239520a8eb3d05372773ea" |
| 18 | SRC_URI[sha256sum] = "8153f4e5dadde422d35feaf86bf595266af9d0037389bc418fa87feb0437efb3" |
| 19 | |
| 20 | TARGET_CC_ARCH += "${LDFLAGS}" |
| 21 | |
| 22 | # For native builds we use the host Python |
| 23 | PYTHONRDEPS = "python3 python3-shell python3-io python3-math python3-crypt python3-logging python3-fcntl python3-pickle python3-compression python3-stringold" |
| 24 | PYTHONRDEPS_class-native = "" |
| 25 | |
| 26 | PACKAGECONFIG = "python update-alternatives" |
| 27 | PACKAGECONFIG[python] = ",,,${PYTHONRDEPS}" |
| 28 | PACKAGECONFIG[update-alternatives] = ",,," |
| 29 | |
| 30 | do_install() { |
| 31 | oe_runmake PREFIX=${prefix} DESTDIR=${D} install |
| 32 | if ! ${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'true', 'false', d)}; then |
| 33 | rm -f "${D}${bindir}/update-alternatives" |
| 34 | fi |
| 35 | |
| 36 | if ! ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)}; then |
| 37 | grep -lZ "/usr/bin/env.*python" ${D}${bindir}/* | xargs -0 rm |
| 38 | fi |
| 39 | } |
| 40 | |
| 41 | do_install_append_class-target() { |
| 42 | if [ -e "${D}${bindir}/update-alternatives" ]; then |
| 43 | sed -i ${D}${bindir}/update-alternatives -e 's,/usr/bin,${bindir},g; s,/usr/lib,${nonarch_libdir},g' |
| 44 | fi |
| 45 | } |
| 46 | |
| 47 | # These are empty and will pull python3-dev into images where it wouldn't |
| 48 | # have been otherwise, so don't generate them. |
| 49 | PACKAGES_remove = "${PN}-dev ${PN}-staticdev" |
| 50 | |
| 51 | PACKAGES =+ "update-alternatives-opkg" |
| 52 | FILES_update-alternatives-opkg = "${bindir}/update-alternatives" |
| 53 | RPROVIDES_update-alternatives-opkg = "update-alternatives update-alternatives-cworth" |
| 54 | RREPLACES_update-alternatives-opkg = "update-alternatives-cworth" |
| 55 | RCONFLICTS_update-alternatives-opkg = "update-alternatives-cworth" |
| 56 | |
| 57 | pkg_postrm_update-alternatives-opkg() { |
| 58 | rm -rf $D${nonarch_libdir}/opkg/alternatives |
| 59 | rmdir $D${nonarch_libdir}/opkg || true |
| 60 | } |
| 61 | |
| 62 | BBCLASSEXTEND = "native nativesdk" |
| 63 | |
| 64 | CLEANBROKEN = "1" |