Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Framework for layout and rendering of internationalized text" |
| 2 | DESCRIPTION = "Pango is a library for laying out and rendering of text, \ |
| 3 | with an emphasis on internationalization. Pango can be used anywhere \ |
| 4 | that text layout is needed, though most of the work on Pango so far has \ |
| 5 | been done in the context of the GTK+ widget toolkit. Pango forms the \ |
| 6 | core of text and font handling for GTK+-2.x." |
| 7 | HOMEPAGE = "http://www.pango.org/" |
| 8 | BUGTRACKER = "http://bugzilla.gnome.org" |
| 9 | SECTION = "libs" |
| 10 | LICENSE = "LGPLv2.0+" |
| 11 | |
| 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7" |
| 13 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame^] | 14 | GNOMEBASEBUILDCLASS = "meson" |
| 15 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 16 | inherit gnomebase gtk-doc ptest-gnome upstream-version-is-even gobject-introspection |
| 17 | |
| 18 | SRC_URI += "file://run-ptest \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame^] | 19 | file://insensitive-diff.patch" |
| 20 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 21 | SRC_URI[archive.md5sum] = "deb171a31a3ad76342d5195a1b5bbc7c" |
| 22 | SRC_URI[archive.sha256sum] = "1d2b74cd63e8bd41961f2f8d952355aa0f9be6002b52c8aa7699d9f5da597c9d" |
| 23 | |
| 24 | DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi" |
| 25 | |
| 26 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame^] | 27 | PACKAGECONFIG[x11] = ",,virtual/libx11 libxft" |
| 28 | |
| 29 | GTKDOC_ENABLE_FLAG = "-Denable_docs=true" |
| 30 | GTKDOC_DISABLE_FLAG = "-Denable_docs=false" |
| 31 | |
| 32 | GI_ENABLE_FLAG = "-Dgir=true" |
| 33 | GI_DISABLE_FLAG = "-Dgir=false" |
| 34 | |
| 35 | EXTRA_OEMESON_append_class-nativesdk = " ${GI_DISABLE_FLAG}" |
| 36 | |
| 37 | EXTRA_OEMESON_append_class-target = " ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '${GI_ENABLE_FLAG}', \ |
| 38 | '${GI_DISABLE_FLAG}', d)} " |
| 39 | |
| 40 | EXTRA_OEMESON_append_class-target = " ${@bb.utils.contains('GTKDOC_ENABLED', 'True', '${GTKDOC_ENABLE_FLAG}', \ |
| 41 | '${GTKDOC_DISABLE_FLAG}', d)} " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 42 | |
| 43 | LEAD_SONAME = "libpango-1.0*" |
| 44 | LIBV = "1.8.0" |
| 45 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 46 | FILES_${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}" |
| 47 | FILES_${PN}-dev += "${libdir}/pango/${LIBV}/modules/*.la" |
| 48 | |
| 49 | RDEPENDS_${PN}-ptest += "liberation-fonts cantarell-fonts" |
| 50 | |
| 51 | RPROVIDES_${PN} += "pango-modules pango-module-indic-lang \ |
| 52 | pango-module-basic-fc pango-module-arabic-lang" |
| 53 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame^] | 54 | BBCLASSEXTEND = "native nativesdk" |
| 55 | |
| 56 | do_install_append () { |
| 57 | if [ "${PTEST_ENABLED}" != "1" ]; then |
| 58 | rm -rf ${D}${libexecdir}/installed-tests ${D}${datadir}/installed-tests |
| 59 | rmdir --ignore-fail-on-non-empty ${D}${libexecdir} ${D}${datadir} |
| 60 | fi |
| 61 | } |