Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | # |
| 2 | # Copyright (C) 2012 Wind River Systems, Inc. |
| 3 | # |
| 4 | SUMMARY = "Provides a wrapper in Python to LDAP" |
| 5 | DESCRIPTION = "This module provides access to the LDAP \ |
| 6 | (Lightweight Directory Access Protocol) through Python operations \ |
| 7 | instead of C API. The module mainly acts as a wrapper for the \ |
| 8 | OpenLDAP 2.x libraries. Errors will appear as exceptions." |
| 9 | |
| 10 | LICENSE = "PSF" |
| 11 | HOMEPAGE = "http://www.python-ldap.org/" |
| 12 | DEPENDS = "python openldap cyrus-sasl" |
| 13 | |
| 14 | PYPI_PACKAGE = "python-ldap" |
| 15 | inherit pypi setuptools |
| 16 | |
| 17 | LIC_FILES_CHKSUM = "file://LICENCE;md5=a41c82edffa04912007cae1d20cac555" |
| 18 | SRC_URI[md5sum] = "18db2d009150ec1864710fea3ed76173" |
| 19 | SRC_URI[sha256sum] = "6d430ecf040f2fc704ee316d3390cb1f5419c191371e1e131baef54a0e42cef0" |
| 20 | |
| 21 | do_configure_prepend() { |
| 22 | sed -i -e 's:^library_dirs =.*::' setup.cfg |
| 23 | sed -i -e 's:^include_dirs =.*:include_dirs = =/usr/include/sasl/:' setup.cfg |
| 24 | } |
| 25 | |
| 26 | RDEPENDS_${PN} = " \ |
| 27 | ${PYTHON_PN}-pprint \ |
| 28 | ${PYTHON_PN}-threading \ |
| 29 | " |