Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | # TODO: include debian's mtp-tools man page (needs xsltproc-native and |
| 2 | # docbook-xsl-native, or we pregenerate it), add support for doxygen |
| 3 | # generation fully with -natives |
| 4 | DESCRIPTION = "libmtp is an Initiator implementation of the Media Transfer \ |
| 5 | Protocol (MTP) in the form of a library suitable primarily for POSIX \ |
| 6 | compliant operating systems" |
| 7 | SUMMARY = "libmtp is an Initiator implementation of the Media Transfer Protocol (MTP)" |
| 8 | HOMEPAGE = "http://libmtp.sourceforge.net/" |
| 9 | LICENSE = "LGPL-2.1+" |
| 10 | LIC_FILES_CHKSUM = "\ |
| 11 | file://COPYING;md5=0448d3676bc0de00406af227d341a4d1 \ |
| 12 | file://src/ptp.c;beginline=3;endline=22;md5=dafe6cfd1782f56471bb94ab06624c1f \ |
| 13 | file://examples/albums.c;beginline=5;endline=21;md5=84f4e55dfec49e898b7f68a828c15620 \ |
| 14 | " |
| 15 | |
| 16 | DEPENDS += "libusb1 gettext-native" |
| 17 | |
| 18 | SCM_URI = "git://git.code.sf.net/p/libmtp/code" |
| 19 | SRC_URI = "\ |
| 20 | ${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz \ |
| 21 | file://69-libmtp.rules \ |
| 22 | file://glibc-2.20.patch \ |
| 23 | " |
| 24 | SRC_URI[md5sum] = "f80e45c0e6e5798c434bb1c26a7b602d" |
| 25 | SRC_URI[sha256sum] = "787679171baf8b3cf2fcc03196c705ab4d7cbc969bd71f9d3696be1ce7f1c63a" |
| 26 | |
| 27 | # Currently we use a pregenerated rules file produced by mtp-hotplug, rather |
| 28 | # than having to depend upon libmtp-native or run mtp-hotplug in a postinst. |
| 29 | do_unpack[vardeps] += "skip_udev_rules_generation" |
| 30 | do_unpack[postfuncs] += "skip_udev_rules_generation" |
| 31 | |
| 32 | skip_udev_rules_generation () { |
| 33 | sed -i -e '/^noinst_DATA=/,/util\/mtp-hotplug -H/d' ${S}/Makefile.am |
| 34 | cp ${WORKDIR}/69-libmtp.rules ${S}/ |
| 35 | } |
| 36 | |
| 37 | inherit autotools pkgconfig lib_package |
| 38 | |
| 39 | EXTRA_OECONF += "--disable-rpath" |
| 40 | |
| 41 | PACKAGECONFIG ?= "\ |
| 42 | ${@bb.utils.contains('DISTRO_FEATURES', 'largefile$', 'largefile', '', d)} \ |
| 43 | " |
| 44 | PACKAGECONFIG[doxygen] = "--enable-doxygen,--disable-doxygen" |
| 45 | PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile" |
| 46 | PACKAGECONFIG[mtpz] = "--enable-mtpz,--disable-mtpz,libgcrypt" |
| 47 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 48 | PACKAGES =+ "libmtp-common libmtp-runtime" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 49 | |
| 50 | RDEPENDS_${PN} += "libmtp-common" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 51 | RRECOMMENDS_${PN} += "libmtp-runtime ${PN}-bin" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 52 | FILES_${PN}-dbg += "${nonarch_base_libdir}/udev/.debug/*" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 53 | FILES_libmtp-common = "${nonarch_base_libdir}/udev/rules.d/*" |
| 54 | SUMMARY_libmtp-common = "The udev rules file for MTP devices" |
| 55 | FILES_libmtp-runtime = "${nonarch_base_libdir}/udev/mtp-probe" |
| 56 | DEPENDS_libmtp-runtime = "libmtp-common" |
| 57 | SUMMARY_libmtp-runtime = "mtp-probe, used for the MTP udev rules" |
| 58 | DESCRIPTION_libmtp-runtime = "This package provides mtp-probe, a program to probe newly connected device interfaces from userspace to determine if they are MTP devices, used for udev rules." |