Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "A PKCS" |
| 2 | DESCRIPTION = "\ |
| 3 | Engine_pkcs11 is an implementation of an engine for OpenSSL. It can be \ |
| 4 | loaded using code, config file or command line and will pass any function \ |
| 5 | call by openssl to a PKCS cards and software for using smart cards in PKCS" |
| 6 | HOMEPAGE = "https://github.com/OpenSC/engine_pkcs11" |
| 7 | SECTION = "Development/Libraries" |
| 8 | LICENSE = "LGPLv2.1+" |
| 9 | LIC_FILES_CHKSUM = "file://src/engine_pkcs11.h;beginline=1;endline=26;md5=973a19f8a6105de047f2adfbbfc04c33" |
| 10 | DEPENDS = "openssl libp11" |
| 11 | |
| 12 | SRC_URI = "git://github.com/OpenSC/engine_pkcs11.git" |
| 13 | SRCREV = "132fcf2c8b319f9f4b2ebdc8dcb54ff496dc0519" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | inherit autotools pkgconfig |
| 18 | |
| 19 | EXTRA_OECONF = "\ |
| 20 | --disable-static \ |
| 21 | --libdir ${libdir}/engines \ |
| 22 | " |
| 23 | |
| 24 | do_install_append () { |
| 25 | rm -f ${D}${libdir}/engines/libpkcs11.la |
| 26 | } |
| 27 | |
| 28 | FILES_${PN} += "${libdir}/engines/libpkcs11${SOLIBSDEV}" |
| 29 | FILES_${PN}-dbg += "${libdir}/engines/.debug/" |
| 30 | |
| 31 | RDEPENDS_${PN} += "openssl libp11 opensc" |