Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 1 | SUMMARY = "1-Wire file system" |
| 2 | DESCRIPTION = "OWFS is an easy way to use the powerful 1-wire system of Dallas/Maxim" |
| 3 | HOMEPAGE = "http://www.owfs.org/" |
| 4 | SECTION = "console/network" |
| 5 | |
| 6 | LICENSE = "GPLv2 & LGPLv2" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=12a64df1cc87275e940cab05ee75c37d \ |
| 8 | file://COPYING.LIB;md5=16ff3ffebed582e19ea7a4f48ec77b42" |
| 9 | |
| 10 | DEPENDS = "fuse virtual/libusb0" |
| 11 | # v3.2p2 |
| 12 | SRCREV = "93c1f36d9ac481075287da331d5184f590f8c0fa" |
| 13 | SRC_URI = "git://github.com/owfs/owfs \ |
| 14 | file://owhttpd \ |
| 15 | file://owserver \ |
| 16 | file://0001-include-sys-sysmacros.h-for-major.patch \ |
| 17 | " |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | inherit autotools-brokensep update-rc.d pkgconfig |
| 22 | |
| 23 | EXTRA_OECONF = " \ |
| 24 | --with-fuseinclude=${STAGING_INCDIR} \ |
| 25 | --with-fuselib=${STAGING_LIBDIR} \ |
| 26 | --enable-owfs \ |
| 27 | --enable-owhttpd \ |
| 28 | --enable-w1 \ |
| 29 | --disable-swig \ |
| 30 | --disable-owtcl \ |
| 31 | --disable-owphp \ |
| 32 | --disable-owpython \ |
| 33 | --disable-owperl \ |
| 34 | " |
| 35 | |
| 36 | do_install_prepend() { |
| 37 | install -d ${D}${sysconfdir}/default/ |
| 38 | install -d ${D}${sysconfdir}/init.d/ |
| 39 | install -m 0755 ${WORKDIR}/owhttpd ${D}${sysconfdir}/init.d/owhttpd |
| 40 | install -m 0755 ${WORKDIR}/owserver ${D}${sysconfdir}/init.d/owserver |
| 41 | } |
| 42 | |
| 43 | PACKAGES =+ "owftpd owhttpd owserver owshell libowcapi libow libownet owmon owtap" |
| 44 | |
| 45 | DESCRIPTION_owftpd = "Anoymous FTP server for 1-wire access" |
| 46 | DESCRIPTION_owhttpd = "Tiny webserver for 1-wire control" |
| 47 | DESCRIPTION_owserver = "Backend server (daemon) for 1-wire control" |
| 48 | DESCRIPTION_owshell = "owdir owread owwrite owpresent owget - lightweight owserver access" |
| 49 | DESCRIPTION_libowcapi = "easy C-language 1-wire interface " |
| 50 | DESCRIPTION_libow = "easy C-language 1-wire interface to the owserver protocol" |
| 51 | DESCRIPTION_libownet = "easy C-language 1-wire interface to the owserver protocol" |
| 52 | DESCRIPTION_owmon = "Monitor for owserver settings and statistics" |
| 53 | DESCRIPTION_owtap = "Packet sniffer for the owserver protocol" |
| 54 | |
| 55 | FILES_owftpd = "${bindir}/owftpd" |
| 56 | FILES_owhttpd = "${bindir}/owhttpd ${sysconfdir}/init.d/owhttpd" |
| 57 | FILES_owserver = "${bindir}/owserver ${sysconfdir}/init.d/owserver" |
| 58 | FILES_owshell = "${bindir}/owread ${bindir}/owwrite \ |
| 59 | ${bindir}/owdir ${bindir}/owpresent \ |
| 60 | ${bindir}/owget ${bindir}/owside" |
| 61 | FILES_owmon = "${bindir}/owmon" |
| 62 | FILES_owtap = "${bindir}/owtap" |
| 63 | FILES_libowcapi = "${libdir}/libowcapi-*" |
| 64 | FILES_libow = "${libdir}/libow-*" |
| 65 | FILES_libownet = "${libdir}/libownet-*" |
| 66 | |
| 67 | INITSCRIPT_PACKAGES = "owhttpd owserver" |
| 68 | INITSCRIPT_NAME_owserver = "owserver" |
| 69 | INITSCRIPT_NAME_owhttpd = "owhttpd" |
| 70 | INITSCRIPT_PARAMS_owserver = "defaults 20" |
| 71 | INITSCRIPT_PARAMS_owhttpd = "defaults 21" |