Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "GStreamer multimedia framework" |
| 2 | DESCRIPTION = "GStreamer is a multimedia framework for encoding and decoding video and sound. \ |
| 3 | It supports a wide range of formats including mp3, ogg, avi, mpeg and quicktime." |
| 4 | HOMEPAGE = "http://gstreamer.freedesktop.org/" |
| 5 | BUGTRACKER = "https://bugzilla.gnome.org/enter_bug.cgi?product=Gstreamer" |
| 6 | SECTION = "multimedia" |
| 7 | LICENSE = "LGPLv2+" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605 \ |
| 9 | file://gst/gst.h;beginline=1;endline=21;md5=8e5fe5e87d33a04479fde862e238eaa4" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 10 | DEPENDS = "glib-2.0 libxml2 bison-native flex-native glib-2.0-native" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | |
| 12 | PR = "r2" |
| 13 | |
| 14 | SRC_URI = "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.bz2 \ |
| 15 | file://check_fix.patch \ |
| 16 | file://gst-inspect-check-error.patch \ |
| 17 | file://0001-baseparse-Fix-self-comparison-always-evaluates-to-tr.patch \ |
| 18 | file://0001-parse-make-grammar.y-work-with-Bison-3.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 19 | file://0002-gst-glib2.m4-don-t-do-crazy-things-to-GLIB_CFLAGS.patch \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 20 | " |
| 21 | |
| 22 | SRC_URI[md5sum] = "a0cf7d6877f694a1a2ad2b4d1ecb890b" |
| 23 | SRC_URI[sha256sum] = "e556a529e0a8cf1cd0afd0cab2af5488c9524e7c3f409de29b5d82bb41ae7a30" |
| 24 | |
| 25 | inherit autotools pkgconfig gettext |
| 26 | |
| 27 | GSTREAMER_DEBUG ?= "--disable-debug" |
| 28 | EXTRA_OECONF = "--disable-docbook --disable-gtk-doc \ |
| 29 | --disable-dependency-tracking --disable-check \ |
| 30 | --disable-examples --disable-tests \ |
| 31 | --disable-valgrind ${GSTREAMER_DEBUG} \ |
| 32 | --disable-introspection \ |
| 33 | " |
| 34 | |
| 35 | CACHED_CONFIGUREVARS += "ac_cv_header_valgrind_valgrind_h=no" |
| 36 | |
| 37 | # apply gstreamer hack after Makefile.in.in in source is replaced by our version from |
| 38 | # ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in, but before configure is executed |
| 39 | # http://lists.linuxtogo.org/pipermail/openembedded-core/2012-November/032233.html |
| 40 | oe_runconf_prepend() { |
| 41 | sed -i -e "1a\\" -e 'GETTEXT_PACKAGE = @GETTEXT_PACKAGE@' ${S}/po/Makefile.in.in |
| 42 | } |
| 43 | |
| 44 | #do_compile_prepend () { |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 45 | # mv ${WORKDIR}/gstregistrybinary.[ch] ${S}/gst/ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 46 | #} |
| 47 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 48 | FILES_${PN} += " ${libdir}/gstreamer-0.10/*.so" |
| 49 | FILES_${PN}-dev += " ${libdir}/gstreamer-0.10/*.la ${libdir}/gstreamer-0.10/*.a" |
| 50 | FILES_${PN}-dbg += " ${libdir}/gstreamer-0.10/.debug/ ${libexecdir}/gstreamer-0.10/.debug/" |