Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "MusicBrainz client library" |
| 2 | DESCRIPTION = "The MusicBrainz client is a library which can be built into other programs. The library allows you to access the data held on the MusicBrainz server." |
| 3 | HOMEPAGE = "http://musicbrainz.org" |
| 4 | LICENSE = "LGPLv2.1+" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=fbc093901857fcd118f065f900982c24" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 6 | DEPENDS = "expat libxml2 libxml2-native neon neon-native" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 7 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 8 | PV = "5.1.0+git${SRCPV}" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 9 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 10 | SRCREV = "44c05779dd996035758f5ec426766aeedce29cc3" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | SRC_URI = "git://github.com/metabrainz/libmusicbrainz.git \ |
| 12 | file://allow-libdir-override.patch " |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 16 | inherit cmake pkgconfig |
| 17 | |
| 18 | do_configure_prepend() { |
| 19 | # The native build really doesn't like being rebuilt, so delete |
| 20 | # it if it's already present. Also delete all other files not |
| 21 | # known to Git to fix subsequent invocations of do_configure. |
| 22 | git clean -dfx -e /.pc/ -e /patches/ . |
| 23 | mkdir build-native |
| 24 | cd build-native |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 25 | LDFLAGS="${BUILD_LDFLAGS}" \ |
| 26 | cmake -DCMAKE_C_FLAGS=${BUILD_CFLAGS} \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 27 | -DCMAKE_C_COMPILER=${BUILD_CC} \ |
| 28 | -DCMAKE_CXX_FLAGS=${BUILD_CXXFLAGS} \ |
| 29 | -DCMAKE_CXX_COMPILER=${BUILD_CXX} \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 30 | -DCMAKE_EXE_LINKER_FLAGS=${BUILD_LDFLAGS} \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 31 | .. |
| 32 | make make-c-interface |
| 33 | cd .. |
| 34 | } |
| 35 | |
| 36 | EXTRA_OECMAKE = "-DLIB_INSTALL_DIR:PATH=${libdir} \ |
| 37 | -DIMPORT_EXECUTABLES=build-native/ImportExecutables.cmake" |
| 38 | |
| 39 | # out-of-tree building doesn't appear to work for this package. |
| 40 | B = "${S}" |