Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 1 | SUMMARY = "Python GObject bindings" |
| 2 | HOMEPAGE = "http://www.pygtk.org/" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "LGPLv2.1" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7" |
| 6 | |
| 7 | inherit autotools pkgconfig gnomebase distutils-base gobject-introspection |
| 8 | |
| 9 | PYTHON_BASEVERSION = "2.7" |
| 10 | PYTHON_PN = "python" |
| 11 | |
| 12 | DEPENDS += "gnome-common-native python glib-2.0" |
| 13 | |
| 14 | SRCNAME="pygobject" |
| 15 | SRC_URI = " \ |
| 16 | http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \ |
| 17 | file://0001-configure.ac-add-sysroot-path-to-GI_DATADIR-don-t-se.patch \ |
| 18 | " |
| 19 | |
| 20 | SRC_URI[md5sum] = "3bac63c86bb963aa401f97859464aa90" |
| 21 | SRC_URI[sha256sum] = "3dd3e21015d06e00482ea665fc1733b77e754a6ab656a5db5d7f7bfaf31ad0b0" |
| 22 | |
| 23 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
| 24 | |
| 25 | BBCLASSEXTEND = "native" |
| 26 | |
| 27 | EXTRA_OECONF = "--disable-cairo --with-python=${PYTHON}" |
| 28 | |
| 29 | RDEPENDS_${PN} += "python-setuptools" |
| 30 | RDEPENDS_${PN}_class-native = "" |
| 31 | |
| 32 | do_install_append() { |
| 33 | # Remove files that clash with python3-pygobject; their content is same |
| 34 | rm -rf ${D}${includedir}/pygobject-3.0//pygobject.h ${D}${libdir}/pkgconfig |
| 35 | } |